glassfish
  1. glassfish
  2. GLASSFISH-21640

JMS message in server.log is logged only message key.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1, 4.1.1, 5.0
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None

      Description

      JMS message in server.log is logged only message key.
      So I can not check the url of the broker.

      [2016-12-16T10:16:34.857+0900] [glassfish 4.1] [INFO] [] [javax.enterprise.resource.jms] [tid: _ThreadID=74 _ThreadName=Recovery Helper Thread] [timeMillis: 1481850994857] [levelValue: 800] [[
        addresslist.setjmsservice.provider]]
      
      [2016-12-16T10:16:34.858+0900] [glassfish 4.1] [INFO] [] [javax.enterprise.resource.jms] [tid: _ThreadID=74 _ThreadName=Recovery Helper Thread] [timeMillis: 1481850994858] [levelValue: 800] [[
        jms.connection.url]]
      

      I think this is regression.
      After rev. 62588, LogDomains is not used in appserver/jms/jms-core.

      MQAddressList.java before rev.62588
          static Logger logger = LogDomains.getLogger(MQAddressList.class,  LogDomains.JMS_LOGGER);
      
      MQAddressList.java after rev.62588
          private static final Logger logger = Logger.getLogger(ActiveJmsResourceAdapter.JMS_MAIN_LOGGER);
      

      So I think LogDomains should be used again to obtain the valid logger.

        Activity

        mskdeepak added a comment -

        The change mentioned above(rev. 62588) has changed the logger object.
        Earlier, the following used to work:

        ActiveJmsResourceAdapter.java:1595
        _logger.log(Level.INFO, "jms.connection.url", val);
        

        Now, since we are not using LogDomains, this is not working. So, the following change needs to be made:

        ActiveJmsResourceAdapter.java:1595
        _logger.log(Level.INFO, "jms.connection.url : {0}", new Object[]{val});
        

        The changes made in revision 62588 have changed the logger objects in the JMS module. We need to make the corresponding changes(as shown above) for other log messages affected in this module.

        mskdeepak added a comment -

        Rather than the above temporary solution, this bug requires a change in JMS logging according to the logging guide(https://glassfish.java.net/wiki-archive/Logging%20Guide.html).

        mskdeepak added a comment -

        Resolved in r64458


          People

          • Assignee:
            mskdeepak
            Reporter:
            yama0428
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: