Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.0pe
    • Component/s: ejb_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      237

      Description

      Regular JAR (non EJB, non webapp, non client) are not removed when undeploying
      the EAR on b36.

      Example of application causing this is an application using Facelet
      (jsf-facelets.jar), MyFaces Tomahawk (tomahawk.jar, commons-validator-1.2.0.jar)
      or Velocity (velocity-1.4.jar,velocity-dep-1.4.jar,velocity-tools-generic-1.2.jar).

      On undeploying, you can see :

      [#|2006-02-08T19:35:56.843+0100|INFO|sun-appserver-pe9.0|javax.enterprise.system.util|_ThreadID=19;_ThreadName=Thread-43;C:\Java\glassfish\domains\xxx.yyy\applications\j2ee-apps\zzz\velocity-dep-1.4.jar;4;|UTIL6043:
      Attempt to delete
      C:\Java\glassfish\domains\xxx.yyy\applications\j2ee-apps\zzz\velocity-dep-1.4.jar
      failed after 4 retries|#]

      [#|2006-02-08T19:35:56.843+0100|INFO|sun-appserver-pe9.0|javax.enterprise.system.util|_ThreadID=19;_ThreadName=Thread-43;C:\Java\glassfish\domains\xxx.yyy\applications\j2ee-apps\zzz\velocity-dep-1.4.jar;|UTIL6048:
      Attempt to delete
      C:\Java\glassfish\domains\xxx.yyy\applications\j2ee-apps\zzz\velocity-dep-1.4.jar
      failed; now marked for delete-on-exit|#]

      Even stopping the server does not clean the files ! Hence manual removing of the
      zzz folder has to be operated to perform a clean undeployment (after the stop).

      This result in very painfull development cycle as "redeploy" is failing and we
      have to do the sequence "underploy, stop, remove files, start, deploy" instead.

        Activity

        Mitesh Meswani added a comment -

        Hi bjb,

        Please attach a test war that can reproduce the issue

        Thanks.

        bjb added a comment -

        My attempt to reproduce this one outside of my application are unsucessfull.

        I've also try the "openjar" files that are enclosed here, but the awt does not
        return any file anylysing the log... so, either the script is not correctly
        setup on my machine (the "magic" jar is in the boot path and I can see the
        "magic" line), or the issue is somewhere else... any ideas ?

        Is there anything else I can test to try to locate where is the issue ? and why
        wit h facelet, I mean I got lots of other jar in my application (custom JSF
        component, custom servlet filters, velocity, tomahawk, ...).

        Sanjeeb Sahoo added a comment -

        Hi JB,

        To narrow down the problem, can you please remove all persistence.xml from your
        application and remove reference to persistence.xml (e.g. @PersistenceContext,
        @PersistenceUnit etc.) from your code and try a deploy and redeploy? I know your
        application would not work, but we are just interested in deployment/redeployment.

        Sahoo

        bjb added a comment -

        Allright, I just reproduced the "last issue".

        Good news : this is not something linked with ejb_container. So you can close
        this issue. Yeah

        Bad news : web_container guys got a new issue,
        https://glassfish.dev.java.net/issues/show_bug.cgi?id=354 but they also have a
        "nice" EAR to reproduce the issue.

        Thanks to all the ejb_container team members, now it is up to the web_container
        team members to do some fun-work

        Rgs,
        JB

        Sanjeeb Sahoo added a comment -

        Closing this issue folloing last comment made by JB. The reason he had reopened
        this bug appears to be a bug in web container and hence issue #354 has been
        opened to track that.

        Thanks, JB.

        – Sahoo


          People

          • Assignee:
            Mahesh Kannan
            Reporter:
            bjb
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: