glassfish
  1. glassfish
  2. GLASSFISH-2375

Autodeploying multiple times causes OutOfMemoryError in PermGen

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.1.1_dev
    • Component/s: other
    • Labels:
      None
    • Environment:

      Operating System: Windows 2000
      Platform: PC

    • Issuezilla Id:
      2,375
    • Status Whiteboard:

      911Approved

      Show
      911Approved

      Description

      Enviroment: GlassFish V2b33, Windows 2000, JRE 1.6.0

      Autodeploying and redeploying an EAR file multiple times causes OutOfMemoryError
      in PermGen Space, after which the server hangs and won't even stop with the
      asadmin stop-domain option.

      To resolve this issue you have to add the -XX:MaxPermGenSpace=512m VM option to
      the server before startup.

      I have seen many users report this error, I think I saw someone say it only
      occurred with JRE1.6.

        Activity

        jluehe added a comment -

        Closing as WONTFIX, since there is nothing we can do from GlassFish. The root
        cause of this issue has been in Ajax4jsf and the Java runtime, for which bugs
        have been filed. See above for bug info.

        tjkincaid added a comment -

        Thanks everybody for the excellent efforts that were put forth in tracking this
        issue down. WOW! A nasty one!

        Tom

        harpreet added a comment -

        Approving for v2.1 as Netbeans team requires partial fix to this issue.

        jluehe added a comment -

        Incremental fix: Invoke sun.misc.ClassLoaderUtil.releaseLoader(this) during
        WebappClassLoader.stop(). Invocation occurs reflectively, since
        sun.misc.ClassLoaderUtil does not exist prior to JDK 6.

        Commit logs:

        9.1.1 (SJSAS91_FCS_BRANCH):

        Checking in WebappClassLoader.java;
        /cvs/glassfish/appserv-webtier/src/java/org/apache/catalina/loader/WebappClassLoader.java,v
        <-- WebappClassLoader.java
        new revision: 1.34.6.5; previous revision: 1.34.6.4
        done

        V3:

        Sending WebappClassLoader.java
        Transmitting file data .
        Committed revision 21128.

        pjiricka added a comment -

        cc myself


          People

          • Assignee:
            jluehe
            Reporter:
            coolbeans
          • Votes:
            4 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: