glassfish
  1. glassfish
  2. GLASSFISH-242

Configure the network interface where to bind

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.0pe
    • Component/s: configuration
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      242

      Description

      We need to be able to specify the interface that will be used on glassfish start

      On my machine, I got a 3 net work interface : 1 lan, 1 wifi and a webcam
      speudo-interface.

      Disabling the wifi is easy, but for the webcam I need to unplug the webcam and
      reboot the machine ... Or I get :

      [#|2006-02-09T21:36:07.843+0100|SEVERE|sun-appserver-pe9.0|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;_RequestID=5e36d91d-c272-4639-a75a-890d0dd0edf8;|CORE5071:
      An error occured during initialization
      com.sun.appserv.server.ServerLifecycleException: Cannot bind to URL
      [rmi://0.1.0.5:8686/management/rmi-jmx-connector]:
      javax.naming.CommunicationException [Root exception is
      java.rmi.ConnectIOException: Exception creating connection to: 0.1.0.5; nested
      exception is:
      java.net.NoRouteToHostException: No route to host: no further information]
      at
      com.sun.enterprise.admin.server.core.JmxConnectorLifecycle.onStartup(JmxConnectorLifecycle.java:127)
      at
      com.sun.enterprise.server.ApplicationServer.onStartup(ApplicationServer.java:326)
      at
      com.sun.enterprise.server.ondemand.OnDemandServer.onStartup(OnDemandServer.java:112)
      at com.sun.enterprise.server.PEMain.run(PEMain.java:320)
      at com.sun.enterprise.server.PEMain.main(PEMain.java:254)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.enterprise.server.PELaunch.main(PELaunch.java:212)
      Caused by: java.io.IOException: Cannot bind to URL
      [rmi://0.1.0.5:8686/management/rmi-jmx-connector]:
      javax.naming.CommunicationException [Root exception is
      java.rmi.ConnectIOException: Exception creating connection to: 0.1.0.5; nested
      exception is:
      java.net.NoRouteToHostException: No route to host: no further information]
      at
      javax.management.remote.rmi.RMIConnectorServer.newIOException(RMIConnectorServer.java:814)
      at
      javax.management.remote.rmi.RMIConnectorServer.start(RMIConnectorServer.java:431)
      at
      com.sun.enterprise.admin.jmx.remote.server.rmi.JmxConnectorServerDriver.startConnectorServer(JmxConnectorServerDriver.java:196)
      at
      com.sun.enterprise.admin.server.core.JmxConnectorLifecycle.onStartup(JmxConnectorLifecycle.java:118)
      ... 9 more
      Caused by: javax.naming.CommunicationException [Root exception is
      java.rmi.ConnectIOException: Exception creating connection to: 0.1.0.5; nested
      exception is:
      java.net.NoRouteToHostException: No route to host: no further information]
      at com.sun.jndi.rmi.registry.RegistryContext.bind(RegistryContext.java:122)
      at com.sun.jndi.toolkit.url.GenericURLContext.bind(GenericURLContext.java:208)
      at javax.naming.InitialContext.bind(InitialContext.java:359)
      at javax.management.remote.rmi.RMIConnectorServer.bind(RMIConnectorServer.java:635)
      at
      javax.management.remote.rmi.RMIConnectorServer.start(RMIConnectorServer.java:427)
      ... 11 more
      Caused by: java.rmi.ConnectIOException: Exception creating connection to:
      0.1.0.5; nested exception is:
      java.net.NoRouteToHostException: No route to host: no further information
      at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:587)
      at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:185)
      at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:171)
      at sun.rmi.server.UnicastRef.newCall(UnicastRef.java:306)
      at sun.rmi.registry.RegistryImpl_Stub.bind(Unknown Source)
      at com.sun.jndi.rmi.registry.RegistryContext.bind(RegistryContext.java:116)
      ... 15 more
      Caused by: java.net.NoRouteToHostException: No route to host: no further information
      at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
      at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:525)
      at
      com.sun.enterprise.server.ss.provider.ASClientSocketImpl.connect(ASClientSocketImpl.java:206)
      at java.net.Socket.connect(Socket.java:507)
      at java.net.Socket.connect(Socket.java:457)
      at java.net.Socket.<init>(Socket.java:365)
      at java.net.Socket.<init>(Socket.java:178)
      at
      sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(RMIDirectSocketFactory.java:22)
      at
      sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(RMIMasterSocketFactory.java:128)
      at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:569)
      ... 20 more

      #]

      That is the reason we need to be able to define network interfaces on which to
      bind the server sockets in configuration file.

        Activity

        km105526 added a comment -

        ...

        km105526 added a comment -

        ...

        Tom Mueller added a comment -

        Nandini no longer on project.

        Tom Mueller added a comment -

        This is a dup of 12666 which has been marked as as resolved.

            • This issue has been marked as a duplicate of 12666 ***

          People

          • Assignee:
            Tom Mueller
            Reporter:
            bjb
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: