Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1pe
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      2,571

      Description

      Issue was initially filed against Netbeans. Does not appear to be an IDE issue.
      Seems similar to Issue 2546
      -------------------------------------------------------------------------------
      Hello Sirs

      The following is an output, - from the deploying process of an EJB file-, which
      exposes the nature of a problem I´ve been lately experimenting in my project:

      >Exception [TOPLINK-60] (Oracle TopLink Essentials - 2006.8 (Build 060830)):
      >oracle.toplink.essentials.exceptions.DescriptorException
      >Exception Description: The method [_toplink_setoIddocType_vh] or
      [_toplink_getoIddocType_vh] is not defined in the object
      [org.aemm.appl.entity.COPerson].
      >Internal Exception: java.lang.NoSuchMethodException:
      org.aemm.appl.entity.COPerson._toplink_getoIddocType_vh()
      >Mapping: oracle.toplink.essentials.mappings.OneToOneMapping[oIddocType]
      >Descriptor: RelationalDescriptor(org.aemm.appl.entity.COPerson -->
      [DatabaseTable(CS_PERSON)])

      >Exception [TOPLINK-60] (Oracle TopLink Essentials - 2006.8 (Build 060830)):
      >oracle.toplink.essentials.exceptions.DescriptorException
      >Exception Description: The method [_toplink_setoCity_vh] or
      [_toplink_getoCity_vh] is not defined in the object
      [org.aemm.appl.entity.COPerson].
      >Internal Exception: java.lang.NoSuchMethodException:
      org.aemm.appl.entity.COPerson._toplink_getoCity_vh()
      >Mapping: oracle.toplink.essentials.mappings.OneToOneMapping[oCity]
      >Descriptor: RelationalDescriptor(org.aemm.appl.entity.COPerson -->
      [DatabaseTable(CS_PERSON)])

      The tool I am using is Netbeans 5.5 with Application Server 9 and Toplink. This
      problem appears in several of my project´s entities.

      When I review the java sources I find out that the function actually exists but
      it might be unrecognized by the system, so as when I retry the deployment the
      output is posted again.

      I tried the Netbeans 5.5 "Project Verify" tool but the results are the same. I
      have been reading Toplink´s documentation but it sent me to the Java SDK
      documentation where I found nothing concerning this trouble.

      I´d be quite grateful if anyone of you could help me or give me any Idea.

      For illustration on the problem I include a fragment of the concerning class
      source code:

      @Entity
      @Table( name = "CS_PERSON" )
      @DiscriminatorValue(value="COPerson")
      @PrimaryKeyJoinColumn(name="CIdentity", referencedColumnName="CId")
      public class COPerson extends COContrStar implements Serializable

      { @ManyToOne(targetEntity=COIddocType.class, fetch=FetchType.LAZY, cascade= {CascadeType.REFRESH}

      )
      @JoinColumn(name="DocType",referencedColumnName="DocType")
      protected COIddocType oIddocType;

      @ManyToOne( targetEntity = COCity.class, fetch = FetchType.LAZY, cascade =

      { CascadeType.REFRESH }

      )
      @JoinColumn( name = "CityId", referencedColumnName = "CId" )
      protected COCity oCity;

      public COIddocType getoIddocType()

      { return oIddocType; }

      public void setoIddocType( COIddocType oIddocType )

      { this.oIddocType = oIddocType; }

      public COCity getoCity()

      { return oCity; }

      public void setoCity( COCity oCity )

      { this.oCity = oCity; }

      }

      Thanks in advance
      Alvaro E Martinez M
      alvarommz@yahoo.com

        Activity

        gyorke added a comment -

        You mentioned that you are deploying the application, are you deploying this to
        the appserver or the embedded appserver or is this a Java SE application? Also
        can you provide the entire stacktrace?

        pkrogh added a comment -

        dup of 1624 - the other bug has more information. It also hints at a potential
        work around - remove the unique constraints.

            • This issue has been marked as a duplicate of 1624 ***
        guruwons added a comment -

        The sample entity does not have empty uniqueConstraints defintion, therefore
        this does not seem to be duplicate of 1624.

        Alvaro, could you try again on latest build(v2) and attach the full testcase? I
        could not reproduce it.

        pkrogh added a comment -

        Not able to reproduce.

        Please try against latest build.


          People

          • Assignee:
            tware
            Reporter:
            nityad
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: