Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1pe
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      2,694

      Description

      oracle.toplink.essentials.internal.sessions.AbstractRecord is not thread safe; several member fields are
      modified, but neither 'synchronized ' nor 'volatile' is used.

      If the code is not intended for multi-threaded use, it should be commented to state that it is not thread
      safe.

        Activity

        llc added a comment -

        Same issue applies to oracle.toplink.essentials.internal.sessions.MergeManager and probably a number of
        other classes.

        gfbugbridge added a comment -

        <BT6540750>

        pkrogh added a comment -

        This bug is a duplicate of the broader issue described in 2755

            • This issue has been marked as a duplicate of 2755 ***

          People

          • Assignee:
            tware
            Reporter:
            llc
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: