glassfish
  1. glassfish
  2. GLASSFISH-2950

MOD does not support modulus state field expressions

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1pe
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      2,950

      Description

      JPQL "mod" operator does not allow the modulus to be a state field expression.

      For example, the following JP QL will fail:

      SELECT p FROM Person p WHERE MOD(100, p.age) = 0

      The modulus should be allowed to be any simple arithmetic expression.

        Activity

        mb124283 added a comment -

        Is this a duplicate of issue 2771 "MOD does not allow field expressions on both
        sides" which has been fixed in 9.1pe_b43?

        mkeith added a comment -

        Yup. Sorry, I didn't remember that I entered it last time I hit it.
        Looks like it is fixed, too Thanks.

        gfbugbridge added a comment -

        <BT6552428>

        marina vatkina added a comment -

        closing

            • This issue has been marked as a duplicate of 2771 ***

          People

          • Assignee:
            tware
            Reporter:
            mkeith
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: