glassfish
  1. glassfish
  2. GLASSFISH-3166

"FOR UPDATE" string for Postgres Platform wrong

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1pe
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      3,166

      Description

      Postgres Platform needs to define

      public String getSelectForUpdateString(){
      return " FOR UPDATE";
      }

      currently returns the default value of "FOR UPDATE OF *" which isn't supported
      by Postgres.

      This should correct the problem with issue <a
      href="https://glassfish.dev.java.net/issues/show_bug.cgi?id=3125">3125</a>

        Activity

        tware added a comment -

        This is a duplicate of issue 3127

            • This issue has been marked as a duplicate of 3127 ***

          People

          • Assignee:
            tware
            Reporter:
            jsl123
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: