Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.1pe_dev
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: Other

    • Issuezilla Id:
      3,308

      Description

      Hi,

      I switch from glassfish toplink essentials b45 to b50 and today to b54 and I
      found an error with @Embedded

      I have an entity

      @Entity
      @DiscriminatorValue("3")
      public class CentroFisico extends UnidadOrganizativa implements Serializable {
      ...
      }

      inside there is

      private String telefono;

      @Embedded
      public Direccion getDireccion() {
      return direccion;
      }
      public void setDireccion(Direccion direccion) {
      this.direccion = direccion;
      }

      As the tables are created and i run a SQL to insert some data to start using the
      application, I get an error.

      The problem is that JPA is inserting the fields from the embebable class in the
      physical table UnidadOrganizativa (the parent table of CentroFisico) and not in
      CentroFisico. Like always did until b45.

      This works fine in b45 (and prior versions) , but in b50 and b54 (the two I
      tested) this fails and creates those fields in th parent table.

      To upgrade to lastest versions I will need this problem fixed as this issue
      breaks our code.

      Thanks.

        Activity

        gfbugbridge added a comment -

        <BT6578015>

        pkrogh added a comment -

        Downgrading to a P2, trying to pinpoint what has changed between the two labels
        to cause this.

        Can you please clarify what the symptoms are? Are you getting an exception?
        What exception, and when is it thrown?

        guypelletier added a comment -

        I've reproduced this issue starting with build 49. I'll have a look.

        guypelletier added a comment -

        Starting ...

        guypelletier added a comment -

        Fix has been submitted.

        Problem description: In a joined inheritance strategy the internal default
        table was incorrectly set on the descriptor.

        Existing test, testCreateNewMudTire from
        oracle.toplink.essentials.testing.tests.cmp3.inheritance.
        MixedInheritanceJUnitTestCase was modified to test the fix.

        Tested with Quicklook, entity-persistence-tests and Oracle-internal tests.

        See change log: http://fisheye5.cenqua.com/changelog/glassfish/entity-
        persistence?

        gyorke added a comment -
            • Issue 3346 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            guypelletier
            Reporter:
            carlosrovira
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: