glassfish
  1. glassfish
  2. GLASSFISH-350

REGRESSION : Count, SUM, AVG query tests failing with latest glassfish build.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.0pe_dev
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: PC

    • Issuezilla Id:
      350

      Description

      The query tests when run against the latest nightly build is currently failing.

      SELECT COUNT(t0.CITY) FROM ADDRESS t0, CUSTOMER_TABLE t1 WHERE (t0.ID =
      t1.FK6_FOR_CUSTOMER_TABLE)
      Caught exception queryTest69: java.lang.ClassCastException:
      java.lang.String|#]

      SELECT SUM(t0.QUANTITY) FROM PRODUCT_TABLE t0, PRODUCT_DETAILS t1 WHERE
      (t1.ID = t0.ID)|#]
      Caught exception queryTest70: java.lang.ClassCastException:
      java.lang.Integer|#]

      AVG tests are failing with this error :
      Caused by: java.lang.ClassCastException: java.lang.Integer

        Activity

        pkrogh added a comment -

        Will be fixed in the next drop to CVS

        pkrogh added a comment -

        This is now fixed and checked into CVS.


          People

          • Assignee:
            tware
            Reporter:
            sailajar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: