glassfish
  1. glassfish
  2. GLASSFISH-3572

JBI console does not support update/upgrade fixes in JBI runtime

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 9.1peur1
    • Fix Version/s: 9.1peur1_dev
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      3,572
    • Status Whiteboard:

      91ur1Approved

      Show
      91ur1Approved

      Description

      BT CR 6564957 fixes a problem with uninstalling/reinstalling JBI components with
      already-deployed Service Units. The JBI RT has been changed to provide an
      upgrade use-case to replace uninstall/(re)install. The JBI console started to
      support this back in June, but this screen was disabled.

      For Sierra support (and Kenai if it starts using 9.1ur1) we need to re-enable
      this screen.

      1. change the list of JBI Components to add an action column
      2. change the list of JBI Components to add an upgrade link for each component
      3. provide a new "upgrade component" screen to copy or upload a replacement archive
      4. provide a context-sensitive online help screen.
      5. update existing help screens for list JBI Components to describe this use-case

        Issue Links

          Activity

          mike_wright added a comment -

          this fix introduced a bug; Mark Basler asked me to fix the bug under this
          (already approved) issue;

          for details, see:

          > https://glassfish.dev.java.net/issues/show_bug.cgi?id=3758

          mike_wright added a comment -

          updating new target milestone

          mike_wright added a comment -

          3572 closed (3758 fixed) in promotion on 10/25 (fix available in b07 or recent
          nightly build)

          mike_wright added a comment -
              • Issue 3758 has been marked as a duplicate of this issue. ***
          markrs added a comment -

          This issue has been fixed by performing the steps described.


            People

            • Assignee:
              mike_wright
              Reporter:
              mike_wright
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: