glassfish
  1. glassfish
  2. GLASSFISH-3677

Add a restart server option to the admin console

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      3,677
    • Status Whiteboard:

      v3-prd-item

      Show
      v3-prd-item

      Description

      It would be convenient to be able to completely restart a GlassFish server from
      the admin console only. Currently, you can stop the server from the console,
      but you must then log in to the server's host and start it via one of the host
      OS's available methods. OC4J has this, for example:
      http://blogs.steeplesoft.com/2007/06/15/comparing-the-glassfish-and-oc4j-admin-consoles/
      (second to last paragraph

        Issue Links

          Activity

          dserodio added a comment -
              • Issue 3677 has been confirmed by votes. ***
          km added a comment -

          Byron and I have been discussing the idea of keeping launcher around, to be able
          to do this. I think this is a clean approach.

          It's rather hard to completely restart the server unless there is a watch-dog
          process around.

          A proposal should be seen soon ...

          Anissa Lam added a comment -


          add keyword

          ijuma added a comment -

          Adding myself to cc list.

          Jason Lee added a comment -

          What's the status on this? It seems like it was decided we would not be doing
          this (and I hope that "memory" of mine is wrong). If I do recall correctly,
          we should note that here and close the issue. If not, what's the current status?

          Anissa Lam added a comment -

          We shouldn't close the issue. We are depending on backend. Many user has been
          requesting this since 2.0 timeframe. I have just bump up the priority of #4302
          to P2.

          Byron Nevins added a comment -

          Backend Support is finishes, in place, and waiting!

          Anissa Lam added a comment -

          The feature is in.

          You can do that in 2 places:

          • Server General page, where there is a restart server button next to the stop
            button.
          • Click the 'Restart Required' link in the header will bring you to the page
            where you can look at the changes that required the restart. You will also see
            the restart button in this page.

            People

            • Assignee:
              Anissa Lam
              Reporter:
              Jason Lee
            • Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: