glassfish
  1. glassfish
  2. GLASSFISH-3683

GlassFish leaks memory when large files (static or dynamic) are serviced.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1peur1_dev
    • Component/s: web_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      3,683
    • Status Whiteboard:

      91ur1Approved

      Show
      91ur1Approved

      Description

      I think I have found serious memory leak in Glassfish v2 b58g (final).
      There is an "enterprise application" deployed, it includes: two EJB3 modules and
      one ACC module launched using WebStart.

      This is long story, so here is how did I reproduce the leak:

      when server starts it takes +/- 40-60MB (that's what jconsole says). When I
      launch 30-40 clients on computers that have all the JNLP files cached -
      everything seems ok, but on one computer I disabled an option: "Keep temporary
      files on my computer" and when I launched application few times more, memory
      used by Glassfish started to grow and it has never released it (there is screen
      shot attached, please take a look at it).

      This is very serious issue, in my company we have now huge problem, because we
      cannot switch to Glassfish V2 final, as there are about 100 remote computers
      that need to download new libraries over the Internet. When I start Glassfish,
      it takes less than an hour and server crashes with OutOfMemoryException...

      1. build.xml
        2 kB
        Tim Quinn
      2. domain.xml
        25 kB
        pljosh
      1. 5ThreadMemUsage.PNG
        56 kB
      2. gfv2b45-memory.PNG
        12 kB
      3. gfv2b58g-memory.PNG
        13 kB

        Activity

        jfarcand added a comment -

        Initiate a flush() operation if the buffer max is reached:

        Checking in
        src/java/com/sun/enterprise/web/connector/grizzly/SelectorThreadConfig.java;
        /cvs/glassfish/appserv-http-engine/src/java/com/sun/enterprise/web/connector/grizzly/SelectorThreadConfig.java,v
        <-- SelectorThreadConfig.java
        new revision: 1.31.4.1; previous revision: 1.31
        done
        Checking in
        src/java/com/sun/enterprise/web/connector/grizzly/SocketChannelOutputBuffer.java;
        /cvs/glassfish/appserv-http-engine/src/java/com/sun/enterprise/web/connector/grizzly/SocketChannelOutputBuffer.java,v
        <-- SocketChannelOutputBuffer.java
        new revision: 1.20.2.1.2.1; previous revision: 1.20.2.1
        done

        jfarcand added a comment -

        Update the title as it impact not only JNLP.

        jfarcand added a comment -
            • Issue 3814 has been marked as a duplicate of this issue. ***
        jfarcand added a comment -

        Fix wrong version.

        shreedhar_ganapathy added a comment -

        corrected to 9.1pe ur1 b05


          People

          • Assignee:
            jfarcand
            Reporter:
            pljosh
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: