glassfish
  1. glassfish
  2. GLASSFISH-3684

Changed "Server name" alias for my virtual server's HTTP listener, now WSDL won't display

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 9.1peur1
    • Fix Version/s: 9.1peur1
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: All

    • Issuezilla Id:
      3,684

      Description

      I have a WAR containing a web service deployed to a virtual server. It works
      fine but I noticed the URLs inside of the WSDL point to localhost instead of my
      computer name. I noticed that I had entered "localhost" in the Server Name
      field of the HTTP Listerner that I created for the virtual server. I removed
      the Server Name value then pressed save. Now when I try to access the WSDL
      (ctrl+f5 refresh in Firefox) I get a blank screen. I restarted Glassfish and
      now it shows the WSDL with the correct host name (my computer name).

      I'm using SJSAS 9.1 FCS release on Windows XP.

        Activity

        gfbugbridge added a comment -

        <BT6608641>

        Bhakti Mehta added a comment -

        I do not think this is a bug. The change in virtual server would require a
        restart to update the values

        rdelaplante added a comment -

        Should the web admin GUI tell me that the server needs to be restarted somehow?
        Perhaps put the yellow "Restart required" exclamation in the header like some
        other parts of the admin GUI do. Since it did not do that, I assumed that I did
        not have to restart. When I got a blank screen instead of an error, I thought
        of it as a bug.

        jluehe added a comment -
            • Issue 3686 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            Bhakti Mehta
            Reporter:
            rdelaplante
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: