Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 9.1pe
    • Fix Version/s: V3
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: Other

    • Issuezilla Id:
      3,712
    • Status Whiteboard:

      as91ur1-na

      Show
      as91ur1-na

      Description

      Have an EJB jar file containing another jar file (java library).
      The EJB contains a web service :

      When trying to test the service (e.g. using GlassFish Tester) the exception is
      thrown (probably due to some SPACE_IN_PATH problem on GlassFish) :

      Exception [TOPLINK-30005] (Oracle TopLink Essentials - 2.0 (Build b58c-fcs
      (08/22/2007))): oracle.toplink.essentials.exceptions.PersistenceUnitLoadingException
      Exception Description: An exception was thrown while searching for persistence
      archives with ClassLoader: EJBClassLoader :
      urlSet = [URLEntry :
      file:/space/home/mkuchtiak/NetBeansProjects/space%20in%20dir/CAESAR_Service_Test/build/jar/,
      URLEntry :
      file:/space/home/mkuchtiak/g2/b58/glassfish/domains/domain1/generated/ejb/j2ee-modules/CAESAR_Service_Test/,
      URLEntry :
      file:/space/home/mkuchtiak/NetBeansProjects/space%20in%20dir/CAESAR_Service_Test/build/jar/JPA_109948.jar]
      doneCalled = false
      Parent -> EJBClassLoader :
      urlSet = []
      doneCalled = false
      Parent -> java.net.URLClassLoader@82d210
      Internal Exception: Exception [TOPLINK-30005] (Oracle TopLink Essentials - 2.0
      (Build b58c-fcs (08/22/2007))):
      oracle.toplink.essentials.exceptions.PersistenceUnitLoadingException
      Exception Description: An exception was thrown while searching for persistence
      archives with ClassLoader: EJBClassLoader :
      urlSet = [URLEntry :
      file:/space/home/mkuchtiak/NetBeansProjects/space%20in%20dir/CAESAR_Service_Test/build/jar/,
      URLEntry :
      file:/space/home/mkuchtiak/g2/b58/glassfish/domains/domain1/generated/ejb/j2ee-modules/CAESAR_Service_Test/,
      URLEntry :
      file:/space/home/mkuchtiak/NetBeansProjects/space%20in%20dir/CAESAR_Service_Test/build/jar/JPA_109948.jar]
      doneCalled = false
      Parent -> EJBClassLoader :
      urlSet = []
      doneCalled = false
      Parent -> java.net.URLClassLoader@82d210
      Internal Exception: java.util.zip.ZipException: No such file or directory
      at
      oracle.toplink.essentials.exceptions.PersistenceUnitLoadingException.exceptionSearchingForPersistenceResources(PersistenceUnitLoadingException.java:143)
      at
      oracle.toplink.essentials.ejb.cmp3.EntityManagerFactoryProvider.createEntityManagerFactory(EntityManagerFactoryProvider.java:169)
      at
      javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:110)
      at
      javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:83)
      at entity.ISBNBook.persist(ISBNBook.java:173)
      at entity.ISBNBook.insert(ISBNBook.java:169)
      at testJPA.testJPA.operation(testJPA.java:33)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at
      com.sun.enterprise.security.application.EJBSecurityManager.runMethod(EJBSecurityManager.java:1067)
      at com.sun.enterprise.security.SecurityUtil.invoke(SecurityUtil.java:176)
      at
      com.sun.ejb.containers.BaseContainer.invokeTargetBeanMethod(BaseContainer.java:2895)
      at com.sun.ejb.containers.BaseContainer.intercept(BaseContainer.java:3986)
      at
      com.sun.ejb.containers.WebServiceInvocationHandler.invoke(WebServiceInvocationHandler.java:189)
      at $Proxy86.operation(Unknown Source)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.enterprise.webservice.InvokerImpl.invoke(InvokerImpl.java:81)
      at
      com.sun.enterprise.webservice.EjbInvokerImpl.invoke(EjbInvokerImpl.java:88)
      at com.sun.xml.ws.server.InvokerTube$2.invoke(InvokerTube.java:146)
      at
      com.sun.xml.ws.server.sei.EndpointMethodHandler.invoke(EndpointMethodHandler.java:257)
      at
      com.sun.xml.ws.server.sei.SEIInvokerTube.processRequest(SEIInvokerTube.java:93)
      at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:595)
      at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:554)
      at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:539)
      at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:436)
      at
      com.sun.xml.ws.api.pipe.helper.AbstractTubeImpl.process(AbstractTubeImpl.java:106)
      at
      com.sun.enterprise.webservice.MonitoringPipe.process(MonitoringPipe.java:147)
      at
      com.sun.xml.ws.api.pipe.helper.PipeAdapter.processRequest(PipeAdapter.java:115)
      at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:595)
      at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:554)
      at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:539)
      at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:436)
      at
      com.sun.xml.ws.api.pipe.helper.AbstractTubeImpl.process(AbstractTubeImpl.java:106)
      at com.sun.xml.ws.tx.service.TxServerPipe.process(TxServerPipe.java:317)
      at
      com.sun.enterprise.webservice.CommonServerSecurityPipe.processRequest(CommonServerSecurityPipe.java:218)
      at
      com.sun.enterprise.webservice.CommonServerSecurityPipe.process(CommonServerSecurityPipe.java:129)
      at
      com.sun.xml.ws.api.pipe.helper.PipeAdapter.processRequest(PipeAdapter.java:115)
      at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:595)
      at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:554)
      at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:539)
      at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:436)
      at com.sun.xml.ws.server.WSEndpointImpl$2.process(WSEndpointImpl.java:243)
      at
      com.sun.xml.ws.transport.http.HttpAdapter$HttpToolkit.handle(HttpAdapter.java:444)
      at com.sun.xml.ws.transport.http.HttpAdapter.handle(HttpAdapter.java:244)
      at
      com.sun.xml.ws.transport.http.servlet.ServletAdapter.handle(ServletAdapter.java:135)
      at
      com.sun.enterprise.webservice.Ejb3MessageDispatcher.handlePost(Ejb3MessageDispatcher.java:113)
      at
      com.sun.enterprise.webservice.Ejb3MessageDispatcher.invoke(Ejb3MessageDispatcher.java:87)
      at
      com.sun.enterprise.webservice.EjbWebServiceServlet.dispatchToEjbEndpoint(EjbWebServiceServlet.java:200)
      at
      com.sun.enterprise.webservice.EjbWebServiceServlet.service(EjbWebServiceServlet.java:129)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:831)
      at
      com.sun.enterprise.web.AdHocContextValve.invoke(AdHocContextValve.java:114)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:87)
      at
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:150)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:270)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:637)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:813)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:339)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:261)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:212)
      at
      com.sun.enterprise.web.portunif.PortUnificationPipeline$PUTask.doTask(PortUnificationPipeline.java:361)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)

      See also the Netbeans issue :
      http://www.netbeans.org/issues/show_bug.cgi?id=109948

        Activity

        Bhakti Mehta added a comment -

        Hi
        I need more instructions in trying to set this up (using javaDB not even sure if
        that was a right step)as I tried testing this but in both the cases with and
        without the directory with spaces I run into exceptions where the database
        Ceasar is not found
        com.sun.ejb.containers.WebServiceInvocationHandler.invoke(WebServiceInvocationHandler.java:189)
        ... 62 more Caused by: java.sql.SQLException: The connection was refused because
        the database CAESAR was not found. at
        ....

        I tried with creating a new EJB Module with netbeans in a directory with
        spaces, added an external jar and deployed and tested it and it worked fine. I
        also thought there maybe a problem with the way we setContextClassloaders using
        URLClassloader and created a test program to see if I could get the %20 in the
        urlEntries and that too worked fine.

        Please can you give me the exact steps so I can identify where the problem is
        coming from

        mkuchtiak added a comment -

        See another log file in the Netbeans issue.

        Just try to switch to any existing database and you'll get the exception.

        Bhakti Mehta added a comment -

        Targetting for v3

        Bhakti Mehta added a comment -

        fixed the status whiteboard

        Bhakti Mehta added a comment -

        This seems to be the same problem as issue 3977. Tim has checked in a fix today
        for GF 9.1.1 You can verify by using the next nightly or promoted build of GF 9.1.1

            • This issue has been marked as a duplicate of 3977 ***

          People

          • Assignee:
            Bhakti Mehta
            Reporter:
            mkuchtiak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: