Issue Details (XML | Word | Printable)

Key: GLASSFISH-3725
Type: Bug Bug
Status: Resolved Resolved
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Ryan Lubke
Reporter: dxg
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
glassfish

javascript error - JSF commandLink across different windows

Created: 04/Oct/07 03:21 AM   Updated: 10/Oct/07 08:35 AM   Resolved: 10/Oct/07 08:35 AM
Component/s: web_container
Affects Version/s: 9.1pe
Fix Version/s: 9.1peur1

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: All


Issuezilla Id: 3,725
Tags:
Participants: dxg, gfbugbridge, jluehe and Ryan Lubke


 Description  « Hide

In main browser window(IE for example), define some JSF commandLink tags in
main window, invoke an URL and target to new window. define some commandLink in
new window and target to main window. A javascript error jump out while
clicking on the link in new window.



jluehe added a comment - 04/Oct/07 09:11 AM

-> rlubke


gfbugbridge added a comment - 04/Oct/07 05:00 PM

<BT6613298>


Ryan Lubke added a comment - 08/Oct/07 03:00 PM

Based on the description, I'm not able to reproduce this.

Please attach a WAR that demonstrates the issue.


dxg added a comment - 08/Oct/07 05:45 PM

Due to the large code size, quite hard to extract it out.
Basically, my understanding is that the javascript used by implementation of
jsf commandLink tag conflicts. Each window has its own copy of it(see below).
Seems like they couldn't co-exist.

<script type="text/javascript" language="Javascript">function dpf(f) {var adp =
f.adp;if (adp != null) {for (var i = 0;i < adp.length;i++) {f.removeChild(adp [i]);}}};function apf(f, pvp) {var adp = new Array();f.adp = adp;var ps =
pvp.split(',');for (var i = 0,ii = 0;i < ps.length;i+,ii+) {var p =
document.createElement("input");p.type = "hidden";p.name = ps[i];p.value = ps[i
+ 1];f.appendChild(p);adp[ii] = p;i += 1;}};function jsfcljs(f, pvp, t) {apf(f,
pvp);var ft = f.target;if (t) {f.target = t;}f.submit();f.target = ft;dpf
(f);};</script>


Ryan Lubke added a comment - 09/Oct/07 08:52 AM

There is no way to boil it down to a simple test case?
Can you at least post the JS error(s)?


dxg added a comment - 09/Oct/07 11:57 PM

The js error is dph object error.

To avoid this error, I have changed to use commandButton. Everything is ok.


Ryan Lubke added a comment - 10/Oct/07 08:35 AM

Closing this out as WORKSFORME.

I've tried to reproduce based on the description with no success.
Unfortunately, the JS error provided isn't going to be of help.

If a simple test case can be created demonstrating the issue, then please feel
free to reopen.