glassfish
  1. glassfish
  2. GLASSFISH-3741

JBI: regression cannot go back to cluster applications page

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 9.1peur1
    • Fix Version/s: 9.1peur1_dev
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      3,741
    • Status Whiteboard:

      as911-na

      Show
      as911-na

      Description

      build: 9.1 UR1 10/4 nightly build downloaded from Glassfish site.

      Step to reproduce:

      • create a cluster
      • Select this cluster from the tree node.
      • go to Applications Tab of this cluster
      • Notice that the JBI tab name is: i18n.jbi.cluster.clusterTabName' (BUG #1)
      • go to this JBI tab
      • go back to the Applications tab

      A Null pointer exception is shown on screen. This happens if going back to the
      application tab, going to other tab is fine.

      need to fix both this NPE and the missing resource key.

        Activity

        Anissa Lam added a comment -

        -> mike.

        gfbugbridge added a comment -

        <BT6613840>

        mike_wright added a comment -

        regression due to i18n key moved to wrong resource bundle; need to move it back

        basler added a comment -

        Approved for check into SJSAS91_UR1_BRANCH - regression

        mike_wright added a comment -

        preparing to add back I18n keys into Strings.properties,
        using names similar to the non-JBI tab names

        (also removing the jbi. keys from open-esb separately,
        and updating the open-esb jbi .jsf files to use the gf Strings.properties
        instead of the oe Bundle.properties.

        mike_wright added a comment -

        part 1: I18n tab name fixed in b07 (verified in a recent nightly build)
        part 2: NPE, dup of 3172, not reproducible

        mike_wright added a comment -

        the fix for (the valid part of) this bug was superseded by 3571 changes,
        so there is nothing to merge into 9.1.1


          People

          • Assignee:
            mike_wright
            Reporter:
            Anissa Lam
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: