glassfish
  1. glassfish
  2. GLASSFISH-3743

<BT6613273>Logged in to AS Admin GUI, saw in the server.log: FileNotFoundException:jbi/cluster/inc/alertBox.inc

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.1peur1
    • Fix Version/s: 9.1peur1
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: All

    • Issuezilla Id:
      3,743

      Description

      *********READ-ONLY Data from Bugtraq*********************
      Inside SWAN :http://swsblweb1.central.sun.com:8080/CrPrint?id=6613273
      Outside SWAN :http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6613273
      **********READ-ONLY Data from Bugtraq Ends********
      *********READ-ONLY Data from Bugtraq*********************
      Description Solaris 10 Sparc machines. I installed AS EE 9.1.1 b03 build. Were used 6 machines.On one machine was WS 7. On other 5 machines were configured one AS node per machine and two clustered instances plus DAS on one of these machines. Totally there were 10 clustered instances and one cluster. After the installation I've started AS, nodes, instances and logged in to AS admin GUI. As only I reached next after login page of AS Admin GUI, I saw such messages in the server instance server.log file:

      [#|2007-10-04T15:15:25.174-0700|WARNING|sun-appserver9.1|javax.enterprise.system.stream.err|_ThreadID=34;_ThreadName=httpSSLWorkerThread-4848-1;_RequestID=bf9877c6-14af-4cb1-bc19-c9777afb163f;|java.io.FileNotFoundException: jbi/cluster/inc/alertBox.inc
      ...........................................................................

      (See the full output at the bottom).

      I did not see any correspondent errors on the browser screen.

      I did the full reinstallation, but it did not help, after the reinstallation I saw the same error messages again.

      ==============================================================================
      [#|2007-10-04T15:15:25.174-0700|WARNING|sun-appserver9.1|javax.enterprise.system.stream.err|_ThreadID=34;_ThreadName=httpSSLWorkerThread-4848-1;_RequestID=bf9877c6-14af-4cb1-bc19-c9777afb163f;|java.io.FileNotFoundException: jbi/cluster/inc/alertBox.inc
      at com.sun.jsftemplating.util.IncludeInputStream.startInclude(IncludeInputStream.java:207)
      at com.sun.jsftemplating.util.IncludeInputStream.read(IncludeInputStream.java:79)
      at com.sun.jsftemplating.util.IncludeInputStream.read(IncludeInputStream.java:120)
      at sun.nio.cs.StreamDecoder$CharsetSD.readBytes(StreamDecoder.java:411)
      at sun.nio.cs.StreamDecoder$CharsetSD.implRead(StreamDecoder.java:453)
      at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:183)
      at java.io.InputStreamReader.read(InputStreamReader.java:167)
      at java.io.BufferedReader.fill(BufferedReader.java:136)
      at java.io.BufferedReader.read(BufferedReader.java:157)
      at com.sun.jsftemplating.layout.template.TemplateParser.nextChar(TemplateParser.java:116)
      at com.sun.jsftemplating.layout.template.TemplateParser.skipCommentsAndWhiteSpace(TemplateParser.java:534)
      at com.sun.jsftemplating.layout.template.TemplateLayoutDefinitionManager.accepts(TemplateLayoutDefinitionManager.java:105)
      at com.sun.jsftemplating.layout.LayoutDefinitionManager.getLayoutDefinitionManager(LayoutDefinitionManager.java:278)
      at com.sun.jsftemplating.layout.LayoutDefinitionManager.getLayoutDefinition(LayoutDefinitionManager.java:129)
      at com.sun.jsftemplating.layout.LayoutViewRoot.getLayoutDefinition(LayoutViewRoot.java:291)
      at com.sun.jsftemplating.layout.LayoutViewHandler.createView(LayoutViewHandler.java:160)
      at com.sun.faces.lifecycle.RestoreViewPhase.execute(RestoreViewPhase.java:203)
      at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:251)
      at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:117)
      at com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.execute(PartialTraversalLifecycle.java:80)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:244)
      at com.sun.enterprise.tools.admingui.servlet.DelayedInitFacesServlet.service(DelayedInitFacesServlet.java:89)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:276)
      at java.security.AccessController.doPrivileged(Native Method)
      at javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
      at org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:309)
      at org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:192)
      at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:404)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:317)
      at org.apache.catalina.core.ApplicationFilterChain.access$000(ApplicationFilterChain.java:75)
      at org.apache.catalina.core.ApplicationFilterChain$1.run(ApplicationFilterChain.java:181)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:177)
      at com.sun.webui.jsf.util.UploadFilter.doFilter(UploadFilter.java:240)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:230)
      at org.apache.catalina.core.ApplicationFilterChain.access$000(ApplicationFilterChain.java:75)
      at org.apache.catalina.core.ApplicationFilterChain$1.run(ApplicationFilterChain.java:181)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:177)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:288)
      at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:271)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:202)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:150)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:270)
      at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:637)
      at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
      at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:813)
      at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:339)
      at com.sun.enterprise.web.connector.grizzly.ssl.SSLReadTask.process(SSLReadTask.java:440)
      at com.sun.enterprise.web.connector.grizzly.ssl.SSLReadTask.doTask(SSLReadTask.java:228)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
      at com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)

      #]

      **********READ-ONLY Data from Bugtraq Ends********
      *********READ-ONLY Data from Bugtraq*********************
      Justification Priority changed from [] to [3-Medium]Please look at this XXXXXX 2007-10-04 23:05:50 GMT

      **********READ-ONLY Data from Bugtraq Ends********

        Activity

        Anissa Lam added a comment -

        According to the original bug report:

        fixed in b04, this bug was caused by glassfish changes going into b03 that
        depended on the JBI promotion which was a day late.

            • (#1 of 1): 2007-10-22 13:59:04 GMT-08:00 mark.saunders@sun.com

          People

          • Assignee:
            Anissa Lam
            Reporter:
            gfbugbridge
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: