glassfish
  1. glassfish
  2. GLASSFISH-3744

<BT6612851>After installation of LB on WS 7.0u1 , WS instance fails to start on windows

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: 9.1peur1
    • Fix Version/s: not determined
    • Component/s: load_balancer
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      3,744

      Description

      *********READ-ONLY Data from Bugtraq*********************
      Inside SWAN :http://swsblweb1.central.sun.com:8080/CrPrint?id=6612851
      Outside SWAN :http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6612851
      **********READ-ONLY Data from Bugtraq Ends********
      *********READ-ONLY Data from Bugtraq*********************
      Description –
      **********READ-ONLY Data from Bugtraq Ends********
      *********READ-ONLY Data from Bugtraq*********************
      Description Install WS 7.0 u1

      {Make sure the instance starts up fine}

      Install AS 9.1 ee build 58g - Choose to install the LB plugin
      The server instance fails to start with an error message :

      [03/Oct/2007:15:11:07] failure ( 1840): CORE2253: Error running Init function lo
      ad-modules: dlopen of C:/smitha/ws7-new/plugins/lbplugin/bin/passthrough.dll fai
      led (The specified module could not be found.)

      **********READ-ONLY Data from Bugtraq Ends********
      *********READ-ONLY Data from Bugtraq*********************
      Justification Priority changed from [] to [3-Medium]Error message cannot be XXXXXX 2007-10-04 05:00:46 GMT

      **********READ-ONLY Data from Bugtraq Ends********
      *********READ-ONLY Data from Bugtraq*********************
      Work Around Download the latest LB plugin from : cp /net/koori.sfbay/onestop/glassfish/external/<OS>/aslb/jars/aslb-9.1-MS4-<latest>.jar

      Unjar it and unzip SUNWaspx.zip
      Copy icudt2.dll, icuin2.dll, icuuc2.dll and xerces-c.dll from the lib directory.

      Put the above 4 dll in the same directory as passthrough.dll in <webserver7_install_dir>\plugins\lbplugin\bin.

      **********READ-ONLY Data from Bugtraq Ends********
      *********READ-ONLY Data from Bugtraq*********************
      Work Around The required dlls are available in the AS/lib but the AS/lib is not in the path and hence the the WS instance doesn't start up.The 2 ways to get it working are
      a) have all the dependent dlls in the same location i.e copy icudt2.dll, icuin2.dll, icuuc2.dll and xerces-c.dll from AS lib directory to the <webserver7_install_dir>\plugins\lbplugin\bin
      OR
      b)set the AS/lib in the systems environment . This needs a system restart.

      **********READ-ONLY Data from Bugtraq Ends********

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            pj126383
            Reporter:
            gfbugbridge
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: