glassfish
  1. glassfish
  2. GLASSFISH-3769

JAXBException: <argument name> is not a valid property

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Incomplete
    • Affects Version/s: 9.1peur1
    • Fix Version/s: 9.1peur1
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      3,769

      Description

      This bug was found with the following setups (the ones I have access to)
      ========================================================================
      Microsoft Windows XP SP2, Linux Ubuntu 7.04
      JDK 1.6, JDK 1.6 update 3, JDK 1.6 update 5 (experimental)
      Glassfish v2 (Sun Java System Application Server 9.1 build b58g-fcs)
      NetBeans 6.0 Beta 1, NetBeans 6.0 (nightly build 20071010)

      Description
      ===========
      On a web application project with only one web service NetBeans deploys it fine
      and it works fine too. When the number of web services increases (and methods of
      those services have the same name) NetBeans still deploys the application
      without errors, but some services cease to work.

      Steps to reproduce the defect
      =============================
      1. Decompress the attached file "services.tar.gz" to the folder "services" (this
      project was created in NetBeans using "New Project -> Web -> Web Application",
      and almost all the methods' body are commented)
      2. Open that project folder on NetBeans (preferably 6.0 beta 1)
      3. In the "Projects" sub-window, right-click the project and select "Undeploy
      and deploy" (assuming you have a working Glassfish v2 server)
      4. No exception will be thrown (for now)
      5. Open the admin console via web-browser (localhost:4848) and login
      (admin:adminadmin)
      6. Select "Web Services" and try to test the services or view the WSDLs
      7. Some services will work and some won't, and this is the output at the
      NetBeans output:

      Servlet web service endpoint 'BlocoService' failure
      javax.xml.ws.WebServiceException: class
      br.ufscar.dc.lince.sgpe.services.jaxws.Cria do not have a property of the name
      idBlocoOrigem
      at
      com.sun.xml.ws.server.sei.EndpointArgumentsBuilder$DocLit.<init>(EndpointArgumentsBuilder.java:495)
      at
      com.sun.xml.ws.server.sei.EndpointMethodHandler.createArgumentsBuilder(EndpointMethodHandler.java:133)
      at
      com.sun.xml.ws.server.sei.EndpointMethodHandler.<init>(EndpointMethodHandler.java:106)
      at
      com.sun.xml.ws.server.sei.PayloadQNameBasedDispatcher.<init>(PayloadQNameBasedDispatcher.java:106)
      at
      com.sun.xml.ws.server.sei.EndpointMethodDispatcherGetter.<init>(EndpointMethodDispatcherGetter.java:72)
      at com.sun.xml.ws.server.sei.SEIInvokerTube.<init>(SEIInvokerTube.java:75)
      at
      com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:204)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:467)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:510)
      at
      com.sun.enterprise.webservice.JAXWSServlet.registerEndpoint(JAXWSServlet.java:398)
      at com.sun.enterprise.webservice.JAXWSServlet.doInit(JAXWSServlet.java:252)
      at com.sun.enterprise.webservice.JAXWSServlet.init(JAXWSServlet.java:113)
      at
      org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1178)
      at
      org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:832)
      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:197)
      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:271)
      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:202)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
      at
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:150)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:270)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:637)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:813)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:339)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:261)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:212)
      at
      com.sun.enterprise.web.portunif.PortUnificationPipeline$PUTask.doTask(PortUnificationPipeline.java:361)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)
      Caused by: javax.xml.bind.JAXBException: idBlocoOrigem is not a valid property
      on class br.ufscar.dc.lince.sgpe.services.jaxws.Cria
      at
      com.sun.xml.bind.v2.runtime.JAXBContextImpl.getElementPropertyAccessor(JAXBContextImpl.java:926)
      at
      com.sun.xml.ws.server.sei.EndpointArgumentsBuilder$DocLit.<init>(EndpointArgumentsBuilder.java:484)
      ... 39 more
      javax.xml.ws.WebServiceException: class
      br.ufscar.dc.lince.sgpe.services.jaxws.Cria do not have a property of the name
      idBlocoOrigem
      at
      com.sun.xml.ws.server.sei.EndpointArgumentsBuilder$DocLit.<init>(EndpointArgumentsBuilder.java:495)
      at
      com.sun.xml.ws.server.sei.EndpointMethodHandler.createArgumentsBuilder(EndpointMethodHandler.java:133)
      at
      com.sun.xml.ws.server.sei.EndpointMethodHandler.<init>(EndpointMethodHandler.java:106)
      at
      com.sun.xml.ws.server.sei.PayloadQNameBasedDispatcher.<init>(PayloadQNameBasedDispatcher.java:106)
      at
      com.sun.xml.ws.server.sei.EndpointMethodDispatcherGetter.<init>(EndpointMethodDispatcherGetter.java:72)
      at com.sun.xml.ws.server.sei.SEIInvokerTube.<init>(SEIInvokerTube.java:75)
      at
      com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:204)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:467)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:510)
      at
      com.sun.enterprise.webservice.JAXWSServlet.registerEndpoint(JAXWSServlet.java:398)
      at com.sun.enterprise.webservice.JAXWSServlet.doInit(JAXWSServlet.java:252)
      at com.sun.enterprise.webservice.JAXWSServlet.init(JAXWSServlet.java:113)
      at
      org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1178)
      at
      org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:832)
      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:197)
      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:271)
      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:202)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
      at
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:150)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:270)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:637)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:813)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:339)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:261)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:212)
      at
      com.sun.enterprise.web.portunif.PortUnificationPipeline$PUTask.doTask(PortUnificationPipeline.java:361)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)
      Caused by: javax.xml.bind.JAXBException: idBlocoOrigem is not a valid property
      on class br.ufscar.dc.lince.sgpe.services.jaxws.Cria
      at
      com.sun.xml.bind.v2.runtime.JAXBContextImpl.getElementPropertyAccessor(JAXBContextImpl.java:926)
      at
      com.sun.xml.ws.server.sei.EndpointArgumentsBuilder$DocLit.<init>(EndpointArgumentsBuilder.java:484)
      ... 39 more
      StandardWrapperValve[BlocoService]: PWC1382: Allocate exception for servlet
      BlocoService
      javax.servlet.ServletException
      at com.sun.enterprise.webservice.JAXWSServlet.doInit(JAXWSServlet.java:260)
      at com.sun.enterprise.webservice.JAXWSServlet.init(JAXWSServlet.java:113)
      at
      org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1178)
      at
      org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:832)
      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:197)
      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:271)
      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:202)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
      at
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:150)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:270)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:637)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:813)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:339)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:261)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:212)
      at
      com.sun.enterprise.web.portunif.PortUnificationPipeline$PUTask.doTask(PortUnificationPipeline.java:361)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)
      Caused by: javax.xml.ws.WebServiceException: class
      br.ufscar.dc.lince.sgpe.services.jaxws.Cria do not have a property of the name
      idBlocoOrigem
      at
      com.sun.xml.ws.server.sei.EndpointArgumentsBuilder$DocLit.<init>(EndpointArgumentsBuilder.java:495)
      at
      com.sun.xml.ws.server.sei.EndpointMethodHandler.createArgumentsBuilder(EndpointMethodHandler.java:133)
      at
      com.sun.xml.ws.server.sei.EndpointMethodHandler.<init>(EndpointMethodHandler.java:106)
      at
      com.sun.xml.ws.server.sei.PayloadQNameBasedDispatcher.<init>(PayloadQNameBasedDispatcher.java:106)
      at
      com.sun.xml.ws.server.sei.EndpointMethodDispatcherGetter.<init>(EndpointMethodDispatcherGetter.java:72)
      at com.sun.xml.ws.server.sei.SEIInvokerTube.<init>(SEIInvokerTube.java:75)
      at
      com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:204)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:467)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:510)
      at
      com.sun.enterprise.webservice.JAXWSServlet.registerEndpoint(JAXWSServlet.java:398)
      at com.sun.enterprise.webservice.JAXWSServlet.doInit(JAXWSServlet.java:252)
      ... 29 more
      Caused by: javax.xml.bind.JAXBException: idBlocoOrigem is not a valid property
      on class br.ufscar.dc.lince.sgpe.services.jaxws.Cria
      at
      com.sun.xml.bind.v2.runtime.JAXBContextImpl.getElementPropertyAccessor(JAXBContextImpl.java:926)
      at
      com.sun.xml.ws.server.sei.EndpointArgumentsBuilder$DocLit.<init>(EndpointArgumentsBuilder.java:484)
      ... 39 more

        Activity

        majinmusashi added a comment -

        Created an attachment (id=1202)
        NetBeans project folder

        gfbugbridge added a comment -

        <BT6616580>

        Bhakti Mehta added a comment -

        I have looked at this project and there are multiple Webservices with the same
        WebMethod name with different params in the same package. Looking into this issue .

        Bhakti Mehta added a comment -

        This is not a bug. The Webmethod name is the same in all the different services
        and they lie in the same package. The solution is

        1.Add a RequestWrapper annotation for atleast 4 of the services for eg
        @RequestWrapper(className="foo.bar.AlunoCria") similarly for the others.

        An example is shown here
        @WebMethod(operationName ="echo")
        @RequestWrapper(className="foo.jaxws.Echo2")

        public int echo(@WebParam(name = "string1") String string1)

        { return 1; }

        That will ensure that the wrappers do not override each other and the services
        are accessible. Or

        2.have separate packages for each services


          People

          • Assignee:
            Bhakti Mehta
            Reporter:
            majinmusashi
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: