Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 9.1peur1
    • Fix Version/s: 9.1.1
    • Component/s: monitoring
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      3,773
    • Status Whiteboard:

      as91ur1-na

      Show
      as91ur1-na

      Description

      java.lang.reflect.InvocationTargetException occured when trying to browse JNDI tree.
      Steps to reproduce:
      1. Fresh install glassfish-installer-v2ur1-b04-linux.jar
      2. Go to http://localhost:4848
      3. Click on Application Server - JNDI browsing
      4. check the lof file: java.lang.reflect.InvocationTargetException
      Caused by: javax.naming.NotContextException: UserTransaction cannot be listed
      throwed.

        Activity

        gfbugbridge added a comment -

        <BT6617282>

        Anissa Lam added a comment -

        -> anac

        Anissa Lam added a comment -

        Will fix this in 9.1.1 release.

        anac added a comment -

        In the admingui we call an mbean method "getNames()" from the jndi mbean which
        returns an ArrayList with the names of the "children", however if no children
        exists it throws an exception. We need an API from the backend that tells us
        whether the jndi node has "children" or it should return an empty list and not
        an exception.

        Anissa Lam added a comment -

        This issue was reported before as issue# 3459. Closing this one as duplicate.

            • This issue has been marked as a duplicate of 3459 ***

          People

          • Assignee:
            anac
            Reporter:
            stenlee
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: