glassfish
  1. glassfish
  2. GLASSFISH-3824

When starting up Sun App Server 9, receive exception from jbi component

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1peur1
    • Component/s: jbi
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      3,824

      Description

      Issue filed by NetBeans user http://www.netbeans.org/issues/show_bug.cgi?id=119979
      When starting up Sun App Server 9, receive exception from jbi component.

      Log file is attached.

      Section from log is quoted here:
      <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
      [#|2007-10-25T02:08:32.750+0200|WARNING|sun-
      appserver9.1|javax.enterprise.system.stream.err|_ThreadID=11;_ThreadName=pool-1-thread-2;_RequestID=ff5d71ab-7b0b-49d8-
      97ab-32d93d43b5af;|com.sun.appserv.server.ServerLifecycleException:
      java.lang.LinkageError: loader constraint
      violation in interface itable initialization: when resolving
      method
      "com.sun.jbi.framework.EnvironmentContext.getComponentManager()Lcom/sun/jbi/ComponentManager;"
      the class loader
      (instance of java/net/URLClassLoader) of the current class,
      com/sun/jbi/framework/EnvironmentContext, and the class
      loader (instance of java/net/URLClassLoader) for interface
      com/sun/jbi/EnvironmentContext have different Class objects
      for the type com/sun/jbi/ComponentManager used in the signature
      >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

      1. jbi-jvm.log
        12 kB
        nityad
      2. jbi-server.log
        30 kB
        nityad

        Activity

        nityad added a comment -

        Created an attachment (id=1241)
        server log

        nityad added a comment -

        Created an attachment (id=1242)
        jvm log

        nityad added a comment -

        Added user who noticed issue in cc

        nityad added a comment -

        Additional comments from user. He is unable to login to edit though he has
        java.net id
        "I just installed GlassFish v2 (and I see from the log that the problem does not
        exist there. Should the bug still be kept open to give opportunity for it to be
        corrected on v9?
        GlassFish is from build: b58g-fcs
        I cannot see any more detailed reference of the build of the 9.1 version I have.
        It was latest production release downloaded approx a week ago."

        basler added a comment -

        Can't reproduce this problem


          People

          • Assignee:
            va146370
            Reporter:
            nityad
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: