glassfish
  1. glassfish
  2. GLASSFISH-3839

Crash when starting JSF + RichFaces Web App

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1.1
    • Component/s: web_container
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: All

    • Issuezilla Id:
      3,839
    • Status Whiteboard:

      as91ur1-na

      Show
      as91ur1-na

      Description

      Glassfish V2 b58g-fcs on CentOS DualCore crashes as soon as I start my web
      application.

      The same application runs fine with glassfish v2 b56g on my Windows XP Dualcore
      notebook.

      The below mentioned
      org.richfaces.renderkit.html.gradientimages.PanelMenuGroupGradient
      resource is part of the RichFaces ui jar file. Grepping around I could not find
      this below the 'generated' directory which is filled with lots of else classes
      on the Linux machine but nearly empty on the Windows notebook where I develop
      and deploy with NetBeans 6 20071102.

      These are the final in server.log (tail of trace clipped) - I could not find any
      other indication of problems.

      [#|2007-11-06T00:49:46.882+0100|INFO|sun-appserver9.1|javax.enterprise.resource.webcontainer.jsf.config|_ThreadID=14;_ThreadName=pool-1-thread-4;/interne
      t;|Initializing Sun's JavaServer Faces implementation (1.2_04-b20-p03) for
      context '/internet'|#]

      [#|2007-11-06T00:49:49.651+0100|INFO|sun-appserver9.1|org.ajax4jsf.cache.CacheManager|_ThreadID=14;_ThreadName=pool-1-thread-4;|Selected
      [org.ajax4jsf.ca
      che.LRUMapCacheFactory] cache factory|#]

      [#|2007-11-06T00:49:49.660+0100|INFO|sun-appserver9.1|org.ajax4jsf.cache.LRUMapCacheFactory|_ThreadID=14;_ThreadName=pool-1-thread-4;|Creating
      LRUMap cac
      he instance using parameters:

      {com.sun.faces.injectionProvider=com.sun.faces.vendor.GlassFishInjectionProvider, com.sun.faces.validateXml=true, com.sun.f aces.forceLoadConfiguration=true, javax.faces.STATE_SAVING_METHOD=client, org.richfaces.SKIN=blueSky, com.sun.faces.verifyObjects=true}|#]

      [#|2007-11-06T00:49:49.661+0100|INFO|sun-appserver9.1|org.ajax4jsf.cache.LRUMapCacheFactory|_ThreadID=14;_ThreadName=pool-1-thread-4;|Creating
      LRUMap cac
      he instance of default capacity|#]

      [#|2007-11-06T00:49:49.694+0100|INFO|sun-appserver9.1|org.ajax4jsf.cache.CacheManager|_ThreadID=14;_ThreadName=pool-1-thread-4;|Selected
      [org.ajax4jsf.ca
      che.LRUMapCacheFactory] cache factory|#]

      [#|2007-11-06T00:49:49.695+0100|INFO|sun-appserver9.1|org.ajax4jsf.cache.LRUMapCacheFactory|_ThreadID=14;_ThreadName=pool-1-thread-4;|Creating
      LRUMap cac
      he instance using parameters:{com.sun.faces.injectionProvider=com.sun.faces.vendor.GlassFishInjectionProvider,com.sun.faces.validateXml=true, com.sun.faces.forceLoadConfiguration=true, javax.faces.STATE_SAVING_METHOD=client,org.richfaces.SKIN=blueSky, com.sun.faces.verifyObjects=true}

      |#]

      [#|2007-11-06T00:49:49.695+0100|INFO|sun-appserver9.1|org.ajax4jsf.cache.LRUMapCacheFactory|_ThreadID=14;_ThreadName=pool-1-thread-4;|Creating
      LRUMap cac
      he instance of default capacity|#]

      [#|2007-11-06T00:49:49.788+0100|INFO|sun-appserver9.1|javax.enterprise.system.core.selfmanagement|_ThreadID=10;_ThreadName=main;|SMGT0007:
      Self Managemen
      t Rules service is enabled|#]

      [#|2007-11-06T00:49:49.807+0100|INFO|sun-appserver9.1|javax.enterprise.system.core|_ThreadID=10;_ThreadName=main;|Application
      server startup complete.|#]

      [#|2007-11-06T00:49:50.013+0100|INFO|sun-appserver9.1|javax.enterprise.resource.webcontainer.jsf.config|_ThreadID=15;_ThreadName=httpWorkerThread-4848-1;
      ;|Initializing Sun's JavaServer Faces implementation (1.2_04-b20-p03) for
      context ''|#]

      [#|2007-11-06T00:50:07.903+0100|INFO|sun-appserver9.1|com.sun.jbi.framework|_ThreadID=15;_ThreadName=httpWorkerThread-4848-1;|JBIFW0012:
      JBI framework st
      artup complete.|#]

      [#|2007-11-06T00:50:32.436+0100|SEVERE|sun-appserver9.1|javax.enterprise.system.container.web|_ThreadID=16;_ThreadName=httpSSLWorkerThread-8080-2;_Reques
      tID=f266e71a-2995-4235-8afc-2ea1cbf4abeb;|StandardWrapperValve[Faces Servlet]:
      PWC1406: Servlet.service() for servlet Faces Servlet threw exception
      org.ajax4jsf.resource.ResourceNotFoundException: Resource not registered :
      org.richfaces.renderkit.html.gradientimages.PanelMenuGroupGradient
      at
      org.ajax4jsf.resource.ResourceBuilderImpl.getResource(ResourceBuilderImpl.java:393)
      at
      org.ajax4jsf.resource.ResourceBuilderImpl.getResourceForKey(ResourceBuilderImpl.java:337)
      at
      org.ajax4jsf.resource.InternetResourceService.serviceResource(InternetResourceService.java:155)
      at
      org.ajax4jsf.resource.InternetResourceService.serviceResource(InternetResourceService.java:144)
      at org.ajax4jsf.webapp.BaseFilter.doFilter(BaseFilter.java:265)
      at
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:230)
      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:198)

      1. intranet-logs.tgz
        7 kB
        bernd_zedv
      2. logs.tgz
        7 kB
        bernd_zedv

        Activity

        Ryan Lubke added a comment -

        Glad to see you've made some progress. As to the current RichFaces error you
        have, I can't really say what the problem is. Have you posted to the RichFaces
        forums/mailing list?

        sanandal added a comment -

        "Reclassifying as P4 because this issue is not deemed "must fix" for this v2.1
        release whose primary release driver is SailFin.
        This issue will be scrubbed after this release and will be given the right
        priority for the next release."

        Ryan Lubke added a comment -

        Passing to Ed.

        Ed Burns added a comment -

        bernd, can I ask you to try this again with GlassFish v3?

        bernd_zedv added a comment -

        I do not have the environment and application available to retry the scenario.
        It seems to be not worth to spend any more time in this bug after three years.


          People

          • Assignee:
            Ed Burns
            Reporter:
            bernd_zedv
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: