glassfish
  1. glassfish
  2. GLASSFISH-3975

GlassFish Rails V3 Gem should work with JRuby 1.0.x and JRuby 1.1 versions

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.1pe
    • Fix Version/s: V3
    • Component/s: jruby
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      3,975

      Description

      JRuby 1.1 has changed some core interfaces (never intended to be public) and the
      current Rails support calls old, now missing APIs. Work with the JRuby team to
      establish appropriate public APIs to replace these and a compatibility layer for
      making the gem work on both JRuby 1.0.x and 1.1.

      For example:

      java.lang.NoSuchMethodError:
      org.jruby.Ruby.parse(Ljava/io/Reader;Ljava/lang/String;Lorg/jruby/runtime/DynamicScope;I)Lorg/jruby/ast/Node;
      at
      com.sun.grizzly.jruby.RailsAdapter.serviceDynamicContent(RailsAdapter.java:119)
      at
      com.sun.grizzly.standalone.DynamicContentAdapter.service(DynamicContentAdapter.java:118)
      at
      com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:100)

        Activity

        jfarcand added a comment -

        The patch looks good Can you send it to dev@grizzly.dev.java.net...I will
        then pick it and apply it. Since it is JRuby, I can add it to the 1.7.1 branch
        so you will have an official release to bundle.

        jfarcand added a comment -

        Fix commit in Grizzly:

        Sending modules/jruby/src/main/java/com/sun/grizzly/jruby/RailsAdapter.java
        Sending modules/jruby/src/main/java/com/sun/grizzly/jruby/RubyObjectPool.java
        Transmitting file data ..
        Committed revision 774.

        pramodgo added a comment -

        Hi Jeanfrancois
        This code checkin is not showing up in 1.7.1. Could we get a 1.7.1 with these
        changes.

        Thanks
        Pramod

        pramodgo added a comment -

        The code changes to fix this issue are already committed into the grizzl-jruby
        module trunk and gem published at RubyForge has these bits and it works
        correctly. Hence closing out this issue.

        pramodgo added a comment -
            • Issue 4249 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            pramodgo
            Reporter:
            headius
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: