Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.1pe
    • Fix Version/s: V3
    • Component/s: jruby
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      3,976

      Description

      Static files, such as the Rails image on the default page, are not loading
      correctly. In the GoldSpike WAR deployment model, static file lookup happens
      first; only if a file does not exist is the request dispatched on to the normal
      Rails gem. This appears to match the model taken by typical Rails web front-ends
      like Mongrel and WEBrick, so the Glassfish Rails Gem should be modified to work
      the same way.

        Activity

        Hide
        pramodgo added a comment -

        Reassigning this issue to myself as I am working on the gem

        Show
        pramodgo added a comment - Reassigning this issue to myself as I am working on the gem
        Hide
        pramodgo added a comment -

        With the application deployed on the root context this issue should be seen in
        the latest v0.1.1 of the glassfish gem.
        But there is still one scenario that I have seen when dealing with a subcontext.
        I had filed a bug earlier on this. There is a difference in behavior where for
        e.g. http://localhost:3000/hello/ works correctly w.r.t static content. But if
        the user enters http://localhost:3000/hello will display the index.html
        correctly but the images and javascript scripts will not.

        Show
        pramodgo added a comment - With the application deployed on the root context this issue should be seen in the latest v0.1.1 of the glassfish gem. But there is still one scenario that I have seen when dealing with a subcontext. I had filed a bug earlier on this. There is a difference in behavior where for e.g. http://localhost:3000/hello/ works correctly w.r.t static content. But if the user enters http://localhost:3000/hello will display the index.html correctly but the images and javascript scripts will not.
        Hide
        pramodgo added a comment -

        Reassigning this issue to Vivek.

        Show
        pramodgo added a comment - Reassigning this issue to Vivek.
        Hide
        vivekp added a comment -

        Fixed, will be made part of glassffish gem 0.3.0.

        Show
        vivekp added a comment - Fixed, will be made part of glassffish gem 0.3.0.

          People

          • Assignee:
            vivekp
            Reporter:
            headius
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: