glassfish
  1. glassfish
  2. GLASSFISH-4239

Glassfish needs OpenJPA jars in its lib directory to properly perform runtime enhancement

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Invalid
    • Affects Version/s: 9.0pe
    • Fix Version/s: None
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: Mac OS X
      Platform: Macintosh

    • Issuezilla Id:
      4,239

      Description

      It appears that when I use OpenJPA, if I rely on the JARs being in my EAR file,
      OpenJPA does not properly enhance my entities. Specifically it skips over
      attributes with

      @PersistentCollection.

      It does so silently, which leads to very hard-to-debug behavior.

      If I put the OpenJPA jars in the Glassfish lib directory, the problem goes away.

        Activity

        Mitesh Meswani added a comment -

        We do properly implement methods getClassLoader(), getNewTempClassLoader() and addTransformer() of PersitenceUnitInfo that facilitates bytecode instrumentation as required by the spec. GlassFish works with both EclipseLink and Hibernate using this.

        It might possibly an issue with OpenJPA and may have been fixed in recent versions. Closing this bug as invalid. Please reopen with a reproducible test case if you are still seeing this issue with latest versions of OpenJPA

        sanandal added a comment -

        "Reclassifying as P4 because this issue is not deemed "must fix" for this v2.1
        release whose primary release driver is SailFin.
        This issue will be scrubbed after this release and will be given the right
        priority for the next release."

        harpreet added a comment -

        moving to next release

        Mitesh Meswani added a comment -

        Can you please attach a sample app that demonstrates the behavior


          People

          • Assignee:
            Mitesh Meswani
            Reporter:
            therealbr
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: