glassfish
  1. glassfish
  2. GLASSFISH-443

Got an NPE in container-managed extened persistence context

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.0pe_dev
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: All

    • Issuezilla Id:
      443

      Description

      B41 on solaris.

      Got an NPE in container-managed extened persistence context test scenario. The
      datatypes application was able to create the first row of data in datatypes
      table but throw out an NullPointerException when creating the second row:

      [#|2006-03-20T10:29:36.461-0800|WARNING|sun-appserver-
      pe9.0|oracle.toplink.essentials.file:/space1/appservers/as90pe/domains/domain1/a
      pplications/j2ee-apps/ejb-cmp-datatypesApp/p_entity.jar-
      em|_ThreadID=45;_ThreadName=p: thread-pool-1; w: 434;_RequestID=7a59c5cd-63bb-
      4def-8b44-d418ec13f26d;|
      java.lang.NullPointerException
      at oracle.toplink.essentials.internal.sessions.UnitOfWorkImpl.executeCall
      (UnitOfWorkImpl.java:1339)
      at
      oracle.toplink.essentials.internal.queryframework.DatasourceCallQueryMechanism.e
      xecuteCall(DatasourceCallQueryMechanism.java:213)
      at
      oracle.toplink.essentials.internal.queryframework.DatasourceCallQueryMechanism.e
      xecuteCall(DatasourceCallQueryMechanism.java:199)
      at
      oracle.toplink.essentials.internal.queryframework.DatasourceCallQueryMechanism.i
      nsertObject(DatasourceCallQueryMechanism.java:331)
      at
      oracle.toplink.essentials.internal.queryframework.StatementQueryMechanism.insert
      Object(StatementQueryMechanism.java:176)
      at
      oracle.toplink.essentials.internal.queryframework.StatementQueryMechanism.insert
      Object(StatementQueryMechanism.java:192)
      at
      oracle.toplink.essentials.internal.queryframework.DatabaseQueryMechanism.insertO
      bjectForWrite(DatabaseQueryMechanism.java:457)
      at
      oracle.toplink.essentials.queryframework.InsertObjectQuery.executeCommit
      (InsertObjectQuery.java:74)
      ...

      If type=EXTENDED is not used, the test passed without any error:
      // @PersistenceContext(unitName="em",type=EXTENDED) EntityManager manager;
      @PersistenceContext(unitName="em") EntityManager manager;

      1. ejb-cmp-datatypesApp.ear
        45 kB
        mzh777
      2. pkgMultiPU.zip
        22 kB
        mzh777

        Activity

        mzh777 added a comment -

        Created an attachment (id=152)
        Testing ear file.

        mzh777 added a comment -

        Created an attachment (id=153)
        Testing source code (including ddls for running against oracle and derby)

        marina vatkina added a comment -

        Tom,

        Please check if this issue is a duplicate of others that refer to problems with
        extended persistence context.

        thanks,
        -marina

        shanchen added a comment -

        Seems similar to bug#123. Should have been fixed and checked into CVS on the
        weekend. I'm not sure which B41 was used. Please try the latest build and see
        if the issue still occurs.

            • This issue has been marked as a duplicate of 123 ***
        mzh777 added a comment -

        The NPE were encountered on the 14th nightly build of b41. I installed today's
        build (java_ee_sdk-5_0-fcs-bin-b41-solaris-sparc-21_mar_2006.bin) and the tests
        are passing for the container-managed extended persistence context.


          People

          • Assignee:
            tware
            Reporter:
            mzh777
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: