Issue Details (XML | Word | Printable)

Key: GLASSFISH-471
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: tware
Reporter: pkrogh
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

P3 Issues from Find bugs

Created: 23/Mar/06 10:51 AM   Updated: 30/Nov/10 05:19 PM   Resolved: 24/Mar/06 09:16 AM
Component/s: entity-persistence
Affects Version/s: 9.0pe
Fix Version/s: 9.0pe_dev

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: All


Issuezilla Id: 471
Tags:
Participants: guypelletier, marina vatkina, pkrogh and tware


 Description  « Hide

Bug number 268 contains eight issues of varying priorties. I will close that
bug as a duplcate of two bugs. This one which will be the P3 issues and
another bug which will be p4 issues.

The issues in this bug Are:
1,4,7,8 from 268.
1. - A fix will be provided in the next CVS drop.
4. - A fix will be provided in the next CVS drop.
7. - A fix will be provided in the next CVS drop.
8. - This exception is intentially ignored.

The descriptions are below.

-------------------------------------------------------------------
1. DLS_DEAD_LOCAL_STORE: Dead store to local variable

This instruction assigns a value to a local variable, but the value is not read
by any subsequent instruction. Often, this indicates an error, because the value
computed is never used.

ValidationException.java:[line 667] - args
ExpressionQueryMechanism.java:[line 432] - nonSelectionFields
AggregateCollectionMapping.java:[line 768] - sourceKeys
XMLPlatformException.java:[line 96] - args

-------------------------------------------------------------------
4. NM_VERY_CONFUSING: Very confusing method names

The referenced methods have names that differ only by capitalization.
oracle.toplink.essentials.platform.database.CloudscapePlatform.isCloudScape()
oracle.toplink.essentials.internal.databaseaccess.DatasourcePlatform.isCloudscap
e()

-------------------------------------------------------------------
7. EC_UNRELATED_TYPES: Call to equals() comparing different types

This method calls equals(Object) on two references of different class types with
no common subclasses. Therefore, the objects being compared are unlikely to be
members of the same class at runtime (unless some application classes were not
analyzed, or dynamic class loading can occur at runtime). According to the
contract of equals(), objects of different classes should always compare as
unequal; therefore, according to the contract defined by
java.lang.Object.equals(Object), the result of this comparison will always be
false at runtime.

persistence.antlr.preprocessor.Rule.narrowerVisibility(Rule)
At Rule.java:[line 67]
Reference type persistence.antlr.preprocessor.Rule
Reference type java.lang.String

persistence.antlr.preprocessor.Rule.narrowerVisibility(Rule)
At Rule.java:[line 61]
Reference type persistence.antlr.preprocessor.Rule
Reference type java.lang.String

oracle.toplink.essentials.internal.ejb.cmp3.xml.sequencing.SequencingProcessor.p
reProcessSequenceGenerator(SequenceGenerator)
At SequencingProcessor.java:[line 88]
Reference type
oracle.toplink.essentials.internal.ejb.cmp3.xml.sequencing.SequenceGenerator
Reference type java.lang.String

oracle.toplink.essentials.internal.annotations.AnnotationsSequencingProcessor.pr
eProcessSequenceGenerator
(javax.persistence.SequenceGenerator,java.lang.reflect.AnnotatedElement)
At AnnotationsSequencingProcessor.java:[line 274]
Reference type javax.persistence.SequenceGenerator
Reference type java.lang.String
-------------------------------------------------------------------

8. DE_MIGHT_IGNORE: Method might ignore exception

This method might ignore an exception. In general, exceptions should be handled
or reported in some way, or they should be thrown out of the method.

oracle.toplink.essentials.internal.weaving.TransformerFactory.hasField
(Class,String)
At TransformerFactory.java:[line 337]
Exception class java.lang.Exception
-------------------------------------------------------------------



pkrogh added a comment - 23/Mar/06 10:52 AM

These issues to be fixed one next drop.


pkrogh added a comment - 23/Mar/06 10:56 AM
      • Issue 268 has been marked as a duplicate of this issue. ***

guypelletier added a comment - 23/Mar/06 12:11 PM

Item has been added to this issue.

-------------------------------------------------------------------
5. MF_CLASS_MASKS_FIELD: Class defines field that obscures a superclass field

This class defines a field with the same name as a visible instance field in a
superclass. This is confusing, and may indicate an error if methods update or
access one of the fields when they wanted the other.

In class oracle.toplink.essentials.queryframework.ObjectLevelReadQuery
Masked field
oracle.toplink.essentials.queryframework.ObjectBuildingQuery.lockingClause
Masking field
oracle.toplink.essentials.queryframework.ObjectLevelReadQuery.lockingClause
In ObjectBuildingQuery.java


tware added a comment - 24/Mar/06 08:52 AM

Fixed in latest drop


marina vatkina added a comment - 24/Mar/06 09:16 AM

Added build #