Issue Details (XML | Word | Printable)

Key: GLASSFISH-4779
Type: Bug Bug
Status: Open Open
Priority: Major Major
Assignee: Harshad Vilekar
Reporter: jarol1
Votes: 5
Watchers: 5
Operations

If you were logged in you would be able to see more operations.
glassfish

iiop-listener ip address ignored

Created: 16/Apr/08 12:47 AM   Updated: 08/Feb/12 07:40 PM
Component/s: orb
Affects Version/s: 3.1
Fix Version/s: future release

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: All


Issuezilla Id: 4,779
Tags: 3_1-exclude
Participants: chaoslayer, harpreet, Harshad Vilekar, jarol1 and Ken Cavanaugh


 Description  « Hide

In my domain.xml I have defined 2 additional unencrypted orb listeners on ports
3701 and 3702 on different IP addresses. But when I start glassfish, my settings
are ignored, and iiop service works only on 10.20.32.51 (on ports 3700, 3701,
3702 - I didn't want that!) even though I selected other IP addresses for other
listeners. Server has multiple network cards, 2 of them in bond. It has
10.20.32.51 (bond), 10.10.32.151 and 127.0.0.1. I need the iiop to work on all
IP addresses, but on different ports. Using 0.0.0.0 doesn't have the required
effect, since then I can't jndi from remote machine on 10.10.32.151.

<iiop-service client-authentication-required="false">
<orb max-connections="1024" message-fragment-size="1024"
use-thread-pool-ids="thread-pool-1"/>
<iiop-listener address="0.0.0.0" enabled="true" id="orb-listener-1"
port="3700" security-enabled="false"/>
<iiop-listener address="10.10.32.151" enabled="true" id="orb-listener-2"
port="3701" security-enabled="false"/>
<iiop-listener address="10.20.32.51" enabled="true" id="orb-listener-3"
port="3702" security-enabled="false"/>
<iiop-listener address="0.0.0.0" enabled="true" id="SSL" port="3820"
security-enabled="true">
<ssl cert-nickname="s1as" client-auth-enabled="false"
ssl2-enabled="false" ssl3-enabled="true" tls-enabled="true"
tls-rollback-enabled="true"/>
</iiop-listener>
<iiop-listener address="0.0.0.0" enabled="true" id="SSL_MUTUALAUTH"
port="3920" security-enabled="true">
<ssl cert-nickname="s1as" client-auth-enabled="true"
ssl2-enabled="false" ssl3-enabled="true" tls-enabled="true"
tls-rollback-enabled="true"/>
</iiop-listener>
</iiop-service>

This bug is present in both Glassfish V2ur2 and Glassfish V2ur1.



Sort Order: Ascending order - Click to sort in descending order
kenaiadmin made changes - 25/Nov/10 11:56 PM
Field Original Value New Value
issue.field.bugzillaimportkey 4779 36383
Ed Bratt made changes - 08/Feb/12 07:40 PM
Assignee Ken Cavanaugh [ kcavanaugh ] Harshad Vilekar [ hvilekar ]