glassfish
  1. glassfish
  2. GLASSFISH-5136

JMS type "EMBEDDED" with class cast exception on Linux

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 9.1peur2
    • Fix Version/s: V3
    • Component/s: jms
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      5,136

      Description

      Version shown in admin console 9.1_02 (build b04-fcs).
      Ubuntu Linux 8.04

      Sending a message to a queue causes this exception:

      DirectConsumer:Caught Exception delivering
      messagecom.sun.messaging.jmq.io.Packet cannot be cast to
      com.sun.messaging.jms.ra.DirectPacket

      Changing JMS type to "LOCAL" does not help because GF cannot start the broker
      (reported as separate issue).

        Activity

        Sivakumar Thyagarajan added a comment -

        Requesting Satish to investigate

        bernd_zedv added a comment -

        I can confirm that with 9.1.1 (build b45-fcs) JMS of type "EMBEDDED" comes up fine
        and responses to PING. Also type "LOCAL" works fine with this version.

        Satish Kumar added a comment -

        This seems to work fine in 9.1.1. Also confirmed by bernd_zedv. Hence closing
        this bug.


          People

          • Assignee:
            Satish Kumar
            Reporter:
            bernd_zedv
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: