Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1
    • Fix Version/s: 4.0
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      5,263

      Description

      The description for using GlassFish as a service
      (http://wiki.glassfish.java.net/Wiki.jsp?page=FaqRunAsWindowsService) says that
      it is up to the administrator to correctly the set -Xrs flag in the GlassFish
      configuration.

      Actually this is weird, because EVERYBODY that wants to use appservService.exe
      MUST use -Xrs. Or see it the other way: It makes absolutely no sense that
      appservService.exe is NOT taking care of using -Xrs, because appservService.exe
      is a service, and a service must not shutdown at user logoff (what will only
      work when using -Xrs).

      So virtually anybody using appservService.exe will consider it as a bug that
      appservService.exe is not using -Xrs on its own, but relies on the admin setting
      that flag correctly.

        Issue Links

          Activity

          sanandal added a comment -

          "Reclassifying as P4 because this issue is not deemed "must fix" for this v2.1
          release whose primary release driver is SailFin.
          This issue will be scrubbed after this release and will be given the right
          priority for the next release."

          Snjezana Sevo-Zenzerovic added a comment -

          Moving to admin subcategory, assigning to Byron. AFAIK, this is already
          addressed in 3.1 'create-service' command implementation.

          Byron Nevins added a comment -

          This has been documented. Not sure if it is reasonable to fix this low priority
          bug.
          Setting to MS6 for now.

          Byron Nevins added a comment -

          -Xrs is useful to add to asadmin – but only for services. When -Xrs is used
          for the asadmin VM - it will NOT kill the server with ^C at the console when
          server is running in verbose mode.

          Solution - use a copy of asadmin, say "asservicerunner.bat" for services and
          then set -Xrs inside there.

          ref:

          import sun.misc.Signal;
          import sun.misc.SignalHandler;

          /**

          • The idea for this code came from James Pereira, this code
          • looks quite different to the well-structured, logically
          • named class he sent me.
          • The idea is that we register a handler for a Ctrl+C
          • signal and then handle it.
            */
            public class Aaarggh {
            public static void main(String[] args) throws Exception {
            Signal.handle(new Signal("INT"), new SignalHandler ()
            Unknown macro: { public void handle(Signal sig) { System.out.println( "Aaarggh, a user is trying to interrupt me!!"); System.out.println( "(throw garlic at user, say `shoo, go away')"); } }

            );
            for(int i=0; i<100; i++)

            { Thread.sleep(1000); System.out.print('.'); }
          Byron Nevins added a comment -

          appservService.exe is no longer supported so I changed the misleading title of this issue

          Byron Nevins added a comment -

          duplicate of 16140


            People

            • Assignee:
              Byron Nevins
              Reporter:
              mkarg
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: