glassfish
  1. glassfish
  2. GLASSFISH-5309

Better error message needed when processing the Ejb Descriptor

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 9.1peur2
    • Fix Version/s: V3
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      5,309

      Description

      When the <ejb-name> tag in the ejb-jar.xml fie contains an invalid bean, I get
      an error that says only "Error processing EjbDescriptor", followed by a stack
      trace. The error occurs in
      com.sun.enterprise.deployment.util.EjbBundleValidator.accept
      (EjbBundleValidator.java line 238), while trying to load a class. If the stack
      trace could include the name of the class the EjbBundleValidator was trying to
      load, it would be very helpful in finding the offending entry.

      Thanks,

      Steve

        Issue Links

          Activity

          ssaliman added a comment -

          Added this issue as a blocker to issue 986, per the comments in issue 986

          Hong Zhang added a comment -

          I am closing the issue as there is not enough information to reproduce the problem and look into it. And it's unclear whether the issue is still applicable to the current release/code base. If similar problem exists for 3.*, please re-open the issue with a reproducible test case.


            People

            • Assignee:
              Hong Zhang
              Reporter:
              ssaliman
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: