glassfish
  1. glassfish
  2. GLASSFISH-5405

After shutting down v3 domains/domain1/applications/<warname> folder missing for webservices with webapps verion 2.5

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      5,405

      Description

      Filing a bug based on a thread with Hong and Tim
      I can reproduce with 109 based apps which is apps which have webapps version
      2.5, but it seems to work fine with metro wars whose webapp version is 2.4
      To reproduce on trunk
      cd v3/webservices
      mvn install
      copy jsr109-impl/target/jsr109impl-10.0-SNAPSHOT.jar to glassfish/modules of web.zip
      copy http://javaweb.sfbay/~bhakti/v3_issue/webservices*.jar to glassfish/modules
      start server
      deploy a war http://javaweb.sfbay/~bhakti/v3_issue/basicv3-109.war ( You may
      run into an error related to WSGEN failed I am working on that)
      stop the server
      I always find the domains/domain1/applications doe not have the folder
      basicv3-109 as soon as server is shutdown but in between if debug is on I see
      the folder

      Pls let me know I am missing something?
      Regards,
      Bhakti

        Activity

        Bhakti Mehta added a comment -

        This is not a bug As Hong mentioned If the deployment failed, as part of the
        error handling, we will clean up the bits from the server so the server is in a
        consistent state. So it's expected the bits will be removed from the
        applications repository after a failed deployment.


          People

          • Assignee:
            Hong Zhang
            Reporter:
            Bhakti Mehta
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: