glassfish
  1. glassfish
  2. GLASSFISH-559

Virtual HTTP server created while glassfish is running needs restart

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.0pe_dev
    • Component/s: web_container
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: All

    • Issuezilla Id:
      559
    • Status Whiteboard:

      fixed-9.0peur1

      Show
      fixed-9.0peur1

      Description

      While playing around I've created a new virtual HTTP Server (named testserver)
      using the web admin console. I used the same values as the default "server" that
      comes with the domain1 installation (b43).

      I then added a new http listener (named testlistener) for port 9090 also with
      same values as for http-listener-1 (except the port). I tied theses two together
      setting default virtual server on the listener and http listeners on the server.
      When I then try to access my new virtual server on port 9090 I get an empty
      page. The log only tells me that my new server (9090) was started.
      After shutting down the domain and restarting I can access the server as expected.

      I'm not quite sure if this is a defect but since I get no "Restart required" in
      the admin console I assume that the new server should be available without a
      restart.

        Activity

        jfarcand added a comment -

        I suspect it will work if you don't set the default-web module. Looks like this
        bug is simialr to issue:

        https://glassfish.dev.java.net/issues/show_bug.cgi?id=141

        will investigate.

        jfarcand added a comment -

        The workaround consist of:

        + set the default-web module to something else than " "

        or

        + set it to __asadmin, save, and then set it to " ", and save again.

        This is a regression introduced by fixing:

        https://glassfish.dev.java.net/issues/show_bug.cgi?id=463

        will be fixed in b44.

        jfarcand added a comment -

        Fixed the regression:

        hecking in PEWebContainer.java;
        /cvs/glassfish/appserv-core/src/java/com/sun/enterprise/web/PEWebContainer.java,v
        <-- PEWebContainer.java
        new revision: 1.44; previous revision: 1.43
        done

        Thanks for reporting this.

        jfarcand added a comment -
            • Issue 573 has been marked as a duplicate of this issue. ***
        jfarcand added a comment -

        Change fixed in build.

        dochez added a comment -

        Need to be fixed in UR1

        km105526 added a comment -

        ...

        jfarcand added a comment -

        Backported to 9.0 ur1

        Checking in PEWebContainer.java;
        /cvs/glassfish/appserv-core/src/java/com/sun/enterprise/web/PEWebContainer.java,v
        <-- PEWebContainer.java
        new revision: 1.42.2.2; previous revision: 1.42.2.1
        done


          People

          • Assignee:
            jfarcand
            Reporter:
            alxs
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: