glassfish
  1. glassfish
  2. GLASSFISH-5592

Can't run Web application located in folder containing russian characters in path with GlassFish V3

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Incomplete
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      5,592
    • Status Whiteboard:

      gfv3-prelude-included

      Show
      gfv3-prelude-included

      Description

      Product Version: NetBeans IDE Dev (Build 200807170007)
      Java: 1.6.0_07; Java HotSpot(TM) Client VM 10.0-b23
      System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)
      Userdir: C:\Documents and Settings\user\.netbeans\dev

      I've created empty Web Application with server and settings value : GlassFish V3
      , Java EE Version : Java EE 5
      After run application I've got Deployment error.

      See output log below:

      init:
      deps-module-jar:
      deps-ear-jar:
      deps-jar:
      Created dir: C:\Documents and Settings\user\Мои
      документы\NetBeansProjects\WebApplication3\build\web\WEB-INF\classes
      Created dir: C:\Documents and Settings\user\Мои
      документы\NetBeansProjects\WebApplication3\build\web\META-INF
      Copying 1 file to C:\Documents and Settings\user\Мои
      документы\NetBeansProjects\WebApplication3\build\web\META-INF
      Copying 3 files to C:\Documents and Settings\user\Мои
      документы\NetBeansProjects\WebApplication3\build\web
      library-inclusion-in-archive:
      library-inclusion-in-manifest:
      compile:
      compile-jsps:
      Created dir: C:\Documents and Settings\user\Мои
      документы\NetBeansProjects\WebApplication3\dist
      Building jar: C:\Documents and Settings\user\Мои
      документы\NetBeansProjects\WebApplication3\dist\WebApplication3.war
      In-place deployment at C:\Documents and Settings\user\Мои
      документы\NetBeansProjects\WebApplication3\build\web
      deploy?path=C:\Documents and Settings\user\Мои
      документы\NetBeansProjects\WebApplication3\build\web?name=WebApplication3?force=true
      running on GlassFish V3
      Unexpected end of file from server
      Deployment error:
      The module has not been deployed.
      See the server log for details.
      at
      org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:193)
      at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:104)
      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      at sun.reflect.GeneratedMethodAccessor100.invoke(Unknown Source)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at
      org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
      at org.apache.tools.ant.Task.perform(Task.java:348)
      at org.apache.tools.ant.Target.execute(Target.java:357)
      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
      at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
      at
      org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
      at
      org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:273)
      at
      org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:485)
      at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:151)
      Caused by: The module has not been deployed.
      at
      org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:187)
      ... 16 more
      BUILD FAILED (total time: 24 seconds)

        Activity

        peterwx added a comment -

        Added CC.

        Hong Zhang added a comment -

        Can you attach the server.log?

        kumara added a comment -

        Change to status whiteboard for v3 bug tracking

        rashid_vm added a comment -

        Created an attachment (id=1689)
        server log

        rashid_vm added a comment -

        Attached server log

        Tim Quinn added a comment -

        adding CC

        Tim Quinn added a comment -

        Thanks for attaching the server.log. Strangely, the server.log does not contain
        any information about a failed attempt to deploy the application. Are you
        certain that this server.log output from the time when the deployment failed?

        We have tried to reproduce the problem here. In my tests the deployment worked
        fine, although there was an issue later on in the web container. The web
        container team is looking at that part. But without being able to reproduce
        your specific deployment problem or study exceptions and stack traces from the
        server.log it is hard for us to make progress on that part.

        • Tim
        Tim Quinn added a comment -

        OK, I have reproduced this problem now.

        The problem occurs because the NetBeans plug-in sends the path to the directory
        as-is, without encoding it before placing it into the URL. The server, on the
        other hand, expects the incoming URL to be encoded using UTF-8 (as recommended
        by the World-Wide Web Consortium). Because the Russian characters are not legal
        UTF-8 characters, they are discarded when the server does the URL decoding. The
        resulting path is the original path with the Russian characters removed.
        Because that path does not exist the deployment fails.

        I am using a very recent build of GlassFish and I do not see the "unexpected end
        of file" error you see. The server is correctly preparing a report that conveys
        the error condition for return to the client - in this case the NetBeans
        plug-in. I verified that the file-not-found report is returned correctly to the
        command-line tool.

        Peter is working on the NetBeans plug-in so it will encode the URLs it sends to
        the server. I am going to close this deployment issue as "invalid" which is the
        closest category we have to "problem not in GlassFish."

        Peter, will you please update the comments here once you have completed your
        changes? Thanks.

        kumara added a comment -

        v3 defect tracking


          People

          • Assignee:
            Hong Zhang
            Reporter:
            rashid_vm
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: