Details

    • Type: Improvement Improvement
    • Status: Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: V3
    • Fix Version/s: not determined
    • Component/s: other
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: Linux

    • Issuezilla Id:
      5,693

      Description

      Unlike the v2 version of the updatecenter, the v3 version does not support
      post-install or pre-remove processing.

      While many of the functions that would require this can now be handled with OSGi
      (with proper versioning), some cannot - for instance, modification of domain.xml.

      Without support for this feature, the updatetool is simply a file delivery
      mechanism, not an update mechanism.

      I've spoken to the updatecenter2 team, and they tell me that this is a product
      specific feature, and they will not be providing this functionality.

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            msreddy
            Reporter:
            driscoll
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: