Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 9.1peur2
    • Fix Version/s: 4.0_b34
    • Component/s: jms
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: HP

    • Issuezilla Id:
      5,895

      Description

      The command below creates a non-XA JMS connection factory instead of an XA one
      althought it is said XA is default in the documentation.

      "asadmin create-jms-resource --host localhost --port 4848 --user admin --restype
      javax.jms.QueueConnectionFactory jms/TESTPRO_XAConnFactory"

      Another attempt to create an XA JMS connection factory with the following
      command fails to create a connection factory also

      create-jms-resource --host localhost --port 4848 --user admin
      â€"-transaction-support=XATransaction --restype javax.jms.ConnectionFactory
      jms/QSDP_XAConnFactory

      I couldn't find any additional explanation in the docs and also got no answer
      for my question at glassfish forum if I missed something.
      So it seems there is no way to create an XA JMS connection factory from CLI
      commands instead of Admin GUI.

        Activity

        Simon Meng added a comment -

        The required functionality is already in product. The document need be updated properly. See GLASSFISH-18701.

        Simon Meng added a comment -

        The transaction-support attribute can be set properly with property parameter. The following command works fine:
        create-jms-resource --restype javax.jms.ConnectionFactory --property transaction-support=XATransaction jms/QSDP_XAConnFactory

        This issue should be a document issue. Current glassfish document does not mention that transaction-support and some other attributes can be set in property parameter.

        David Zhao added a comment -

        In 3.1.2, create-jms-resource command does not support parameter -transaction-support.

        Tom Mueller added a comment -

        Assigning to correct category (JMS).

        Tom Mueller added a comment -

        Cleared the Fix version field since this issue isn't going to be fixed in V3.

        tronda added a comment -
            • Issue 5895 has been confirmed by votes. ***
        sanandal added a comment -

        "Reclassifying as P4 because this issue is not deemed "must fix" for this v2.1
        release whose primary release driver is SailFin.
        This issue will be scrubbed after this release and will be given the right
        priority for the next release."


          People

          • Assignee:
            Simon Meng
            Reporter:
            bahadir_g
          • Votes:
            2 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: