glassfish
  1. glassfish
  2. GLASSFISH-593

Strange error message: Incompatible argument to fun�

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.0pe
    • Component/s: logging
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      593

      Description

      Deploying application in domain failed; Error loading deployment descriptors
      for module [WebApplication60] – (class: com/sun/xml/ws/model/RuntimeModeler,
      Glassfish (build 41) produces this error message in NetBeans IDE when deploying
      a JAX-WS web service (sometimes, not every time). I think the message should be
      clear(er):

      method: processRpcMethod signature:
      (Lcom/sun/xml/ws/model/JavaMethodImpl;Ljava/lang/String;Ljavax/jws/WebMethod;Lja
      va/lang/String;Ljava/lang/reflect/Method;Ljavax/jws/WebService;)V) Incompatible
      argument to funú)?

      C:\Documents and Settings\Geertjan Wielenga\WebApplication60\nbproject\build-
      impl.xml:537: Deployment error:
      The module has not been deployed.
      See the server log for details.
      BUILD FAILED (total time: 2 seconds)

        Issue Links

          Activity

          dpatil added a comment -

          Email message from: Vijay Ramachandran, so please respond back:

          That method is in JAXWS code base. But what is the environment under which this
          is reproducible ?

          Is the user using Mustang ? If so, ensure that the Mustang build being used is
          the latest one - because there were some API changes which made it Mustang quite
          late.

          Does the user have some JAXWS/JWSDP binaries in the classpath-prefix ? If so,
          that could be another cause of the problem

          dpatil added a comment -

          Taking ownership

          gfbugbridge added a comment -

          <BT6443400>

          vince kraemer added a comment -

          error message improvement initiative

          vijaysr added a comment -

          The developer has not responded back to our queries. I am changing the state to
          FIXED and would request the submitter to try with the latest Mustang build

          geertjan added a comment -

          OK. Sorry for not responding earlier, missed this thread somehow. I haven't seen
          that error for a long time, so must be gone (or I must have stopped making the
          error that caused that message...)


            People

            • Assignee:
              dpatil
              Reporter:
              geertjan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: