glassfish
  1. glassfish
  2. GLASSFISH-6105

Internal Severe Errors in the Log File - during the access of an EJB 3

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: ejb_container
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: All

    • Issuezilla Id:
      6,105
    • Status Whiteboard:

      gfv3-prelude-included

      Show
      gfv3-prelude-included

      Description

      Server: GF v3 prelude b24
      OS: Windows Vista Ultimate 32 bit
      JDK 16u10

      It seems like some internal EJB logs cannot be formatted. This causes lot of log
      output - the functionality, however, seems not to be limited.

      Log file excerpt:

      [#|2008-09-13T15:55:17.234+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|java.util.logging.ErrorManager:
      5: Error in formatting Logrecord|#]

      [#|2008-09-13T15:55:17.234+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|java.util.MissingResourceException:
      Can't find bundle for base name
      com.sun.logging.enterprise.system.container.ejb.LogStrings, locale de_DE|#]

      [#|2008-09-13T15:55:17.234+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1521)|#]

      [#|2008-09-13T15:55:17.234+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1260)|#]

      [#|2008-09-13T15:55:17.234+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at java.util.ResourceBundle.getBundle(ResourceBundle.java:962)|#]

      [#|2008-09-13T15:55:17.234+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at com.sun.logging.LogDomains$1.getResourceBundle(LogDomains.java:260)|#]

      [#|2008-09-13T15:55:17.234+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.getResourceBundle(UniformLogFormatter.java:308)|#]

      [#|2008-09-13T15:55:17.234+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.uniformLogFormat(UniformLogFormatter.java:264)|#]

      [#|2008-09-13T15:55:17.235+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.format(UniformLogFormatter.java:147)|#]

      [#|2008-09-13T15:55:17.235+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at java.util.logging.StreamHandler.publish(StreamHandler.java:179)|#]

      [#|2008-09-13T15:55:17.235+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.FileandSyslogHandler.log(FileandSyslogHandler.java:478)|#]

      [#|2008-09-13T15:55:17.235+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.FileandSyslogHandler$3.run(FileandSyslogHandler.java:234)|#]

      [#|2008-09-13T15:55:17.235+0200|INFO|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|class
      name that failed com.sun.ejb.containers.EjbContainerUtilImpl|#]

      [#|2008-09-13T15:55:17.235+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|java.util.logging.ErrorManager:
      5: Error in formatting Logrecord|#]

      [#|2008-09-13T15:55:17.235+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|java.util.MissingResourceException:
      Can't find bundle for base name
      com.sun.logging.enterprise.system.container.ejb.LogStrings, locale de_DE|#]

      [#|2008-09-13T15:55:17.251+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1521)|#]

      [#|2008-09-13T15:55:17.251+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1260)|#]

      [#|2008-09-13T15:55:17.251+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at java.util.ResourceBundle.getBundle(ResourceBundle.java:962)|#]

      [#|2008-09-13T15:55:17.251+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at com.sun.logging.LogDomains$1.getResourceBundle(LogDomains.java:260)|#]

      [#|2008-09-13T15:55:17.251+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.getResourceBundle(UniformLogFormatter.java:308)|#]

      [#|2008-09-13T15:55:17.251+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.uniformLogFormat(UniformLogFormatter.java:264)|#]

      [#|2008-09-13T15:55:17.251+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.format(UniformLogFormatter.java:147)|#]

      [#|2008-09-13T15:55:17.251+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at java.util.logging.StreamHandler.publish(StreamHandler.java:179)|#]

      [#|2008-09-13T15:55:17.252+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.FileandSyslogHandler.log(FileandSyslogHandler.java:478)|#]

      [#|2008-09-13T15:55:17.252+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.FileandSyslogHandler$3.run(FileandSyslogHandler.java:234)|#]

      [#|2008-09-13T15:55:17.274+0200|INFO|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|class
      name that failed com.sun.ejb.containers.EjbContainerUtilImpl|#]

      [#|2008-09-13T15:55:17.275+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|java.util.logging.ErrorManager:
      5: Error in formatting Logrecord|#]

      [#|2008-09-13T15:55:17.275+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|java.util.MissingResourceException:
      Can't find bundle for base name
      com.sun.logging.enterprise.system.container.ejb.LogStrings, locale de_DE|#]

      [#|2008-09-13T15:55:17.275+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1521)|#]

      [#|2008-09-13T15:55:17.275+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1260)|#]

      [#|2008-09-13T15:55:17.275+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at java.util.ResourceBundle.getBundle(ResourceBundle.java:962)|#]

      [#|2008-09-13T15:55:17.275+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at com.sun.logging.LogDomains$1.getResourceBundle(LogDomains.java:260)|#]

      [#|2008-09-13T15:55:17.275+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.getResourceBundle(UniformLogFormatter.java:308)|#]

      [#|2008-09-13T15:55:17.275+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.uniformLogFormat(UniformLogFormatter.java:264)|#]

      [#|2008-09-13T15:55:17.275+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.UniformLogFormatter.format(UniformLogFormatter.java:147)|#]

      [#|2008-09-13T15:55:17.276+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at java.util.logging.StreamHandler.publish(StreamHandler.java:179)|#]

      [#|2008-09-13T15:55:17.276+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.FileandSyslogHandler.log(FileandSyslogHandler.java:478)|#]

      [#|2008-09-13T15:55:17.276+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|
      at
      com.sun.enterprise.server.logging.FileandSyslogHandler$3.run(FileandSyslogHandler.java:234)|#]

      [#|2008-09-13T15:55:17.276+0200|INFO|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|class
      name that failed com.sun.ejb.containers.EjbContainerUtilImpl|#]

      [#|2008-09-13T15:55:17.276+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|java.util.logging.ErrorManager:
      5: Error in formatting Logrecord|#]

      [#|2008-09-13T15:55:17.276+0200|SEVERE|GlassFish10.0|null|_ThreadID=14;_ThreadName=Thread-4;|java.util.MissingResourceException:
      Can't find bundle for base name
      com.sun.logging.enterprise.system.container.ejb.LogStrings, locale de_DE|#]

        Activity

        kumara added a comment -

        v3 defect tracking

        Mahesh Kannan added a comment -

        This is fixed. Also, this is a Duplicate of 6099

            • This issue has been marked as a duplicate of 6099 ***

          People

          • Assignee:
            Mahesh Kannan
            Reporter:
            abien
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: