glassfish
  1. glassfish
  2. GLASSFISH-6108

Monitoring Statistics Seems Not To Work For WebApps

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: monitoring
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: All

    • Issuezilla Id:
      6,108
    • Status Whiteboard:

      gfv3-prelude-included

      Show
      gfv3-prelude-included

      Description

      Server: GF prelude V3 b24
      OS: Vista Ultimate 32 bit

      Scenario:

      1. All Monitoring "Services": web, http, jvm and thread p. are turned on.
      2. Web app with no-interface EJB 3 is deployed (EJB 3 probably do not matter here).
      3. The war is selected in the monitoring view. The view "all" seems to work.

      After serveral invocations of the servlet the statistics still remain empty.
      Changing it to "all" works. Only filtering for a particular application seems
      not to work.

        Activity

        kumara added a comment -

        v3 defect tracking

        Jennifer Chou added a comment -

        Is there servlet in the web app? If none there would be no servlet statistics.
        There are some internal system web apps for admin console that aren't listed in
        the Application drop-down. But that probably is why you see servlet statistics
        when you select 'All'. 'All' includes all web apps in the web container and
        probably includes the system apps.

        abbagani added a comment -

        Can you please provide the sample app that you were using. I dont see this issue
        with several other wars I deployed.

        abbagani added a comment -

        Marking as works for me, unless a sample is provided for me to reproduce the issue.


          People

          • Assignee:
            abbagani
            Reporter:
            abien
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: