glassfish
  1. glassfish
  2. GLASSFISH-6172

[BLOCKING] Unable to access server instance

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      6,172
    • Status Whiteboard:

      gfv3-prelude-included

      Show
      gfv3-prelude-included

      Description

      GlassFish V3 B25
      JDK 1.5.0_16 B02
      Application: Galactica

      Installed B25 and installed Metro from Update Center. After starting domain,
      accessed server instance http://liua.sfbay.sun.com:8080, I am seeing the
      following exception in server.log. This happens with default domain1 and also
      with a newly created domain named galactica. This issue is easily reproducible.

      The following files are created in modules directory from Metro installation:
      rw-rr- 1 nobody sys 36118 Sep 19 14:38 Metro-LICENSE.txt
      rw-rr- 1 nobody sys 102822 Sep 19 14:38 jsr109-impl.jar
      rw-rr- 1 nobody sys 11324996 Sep 19 14:38 webservices.jar
      rw-rr- 1 nobody sys 5069319 Sep 19 14:38 jaxb.jar

      [#|2008-09-19T16:15:06.482-0700|INFO|GlassFish10.0|org.jvnet.hk2.osgiadapter|_ThreadID=15;_ThreadName=Thread-3;org.glassfish.connectors.gf-connectors-connector
      [77];|Started bundle org.glassfish.connectors.gf-connectors-connector [77]|#]

      [#|2008-09-19T16:15:06.526-0700|INFO|GlassFish10.0|org.jvnet.hk2.osgiadapter|_ThreadID=15;_ThreadName=Thread-3;org.glassfish.core.security
      [57];|Started bundle
      org.glassfish.core.security [57]|#]

      [#|2008-09-19T16:15:06.584-0700|INFO|GlassFish10.0|org.jvnet.hk2.osgiadapter|_ThreadID=15;_ThreadName=Thread-3;org.glassfish.scripting.gf-jruby-connector
      [76];|Started bundle org.glassfish.scripting.gf-jruby-connector [76]|#]

      [#|2008-09-19T16:15:06.660-0700|INFO|GlassFish10.0|org.jvnet.hk2.osgiadapter|_ThreadID=15;_ThreadName=Thread-3;org.glassfish.persistence.jpa-connector
      [90];|Started bundle org.glassfish.persistence.jpa-connector [90]|#]

      [#|2008-09-19T16:15:06.830-0700|SEVERE|GlassFish10.0|javax.enterprise.system.core|_ThreadID=15;_ThreadName=Thread-3;|processorTask.serviceError
      com.sun.enterprise.module.ResolveError: Failed to start
      org.glassfish.webservices.jsr109-impl(JSR-109 implementation to deploy
      Metro):10.0.0.SNAPSHOT
      at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:142)
      at
      org.jvnet.hk2.osgiadapter.OSGiModuleImpl$1$1.loadClass(OSGiModuleImpl.java:275)
      at com.sun.hk2.component.LazyInhabitant.fetch(LazyInhabitant.java:91)
      at com.sun.hk2.component.LazyInhabitant.get(LazyInhabitant.java:106)
      at
      com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:60)
      at org.jvnet.hk2.component.Habitat$1.get(Habitat.java:252)
      at java.util.AbstractList$Itr.next(AbstractList.java:422)
      at
      com.sun.enterprise.v3.services.impl.ContainerMapper.initializeFileURLPattern(ContainerMapper.java:199)
      at
      com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:159)
      at
      com.sun.grizzly.http.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:610)
      at
      com.sun.grizzly.http.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:547)
      at
      com.sun.grizzly.http.DefaultProcessorTask.process(DefaultProcessorTask.java:783)
      at
      com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:152)
      at
      com.sun.enterprise.v3.services.impl.GlassfishProtocolChain.executeProtocolFilter(GlassfishProtocolChain.java:71)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:103)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:89)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at
      com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:67)
      at
      com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:56)
      at
      com.sun.grizzly.util.WorkerThreadImpl.processTask(WorkerThreadImpl.java:325)
      at com.sun.grizzly.util.WorkerThreadImpl.run(WorkerThreadImpl.java:184)
      Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle
      31: package; (package=javax.ejb)
      at org.apache.felix.framework.Felix._resolveBundle(Felix.java:1725)
      at org.apache.felix.framework.Felix._startBundle(Felix.java:1588)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1541)
      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:371)
      at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:136)
      ... 20 more

      #]

        Activity

        meenap added a comment -

        Galactica executed successfully for 3 days on Solaris 10 Sparc with B27 +
        JDK1.5.0_17 B02 + Metro from UC. So I am closing this bug.

        meenap added a comment -

        Just tried Metro with B28b on both Windows XP and Solaris 10 Sparc and seeing
        this issue again. After installation of Metro, accessing the server instance at
        port 8080 gives the following error. This is with JDK1.6.0_10. If I uninstall
        Metro, I am able to access the instance.

        rw-rr- 1 nobody sys 36118 Oct 21 12:09 Metro-LICENSE.txt
        rw-rr- 1 nobody sys 112459 Oct 21 12:09 jsr109-impl.jar
        rw-rr- 1 nobody sys 5069827 Oct 21 12:09 jaxb.jar
        rw-rr- 1 nobody sys 11330895 Oct 21 12:09 webservices.jar

        [#|2008-10-21T12:34:32.265-0700|SEVERE|glassfish|javax.enterprise.system.core|_ThreadID=15;_ThreadName=Thread-3;|HTTP
        Processing error
        com.sun.enterprise.module.ResolveError: Failed to start
        org.glassfish.webservices.jsr109-impl(JSR-109 implementation to deploy
        Metro):10.0.0.b28
        at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:143)
        at
        org.jvnet.hk2.osgiadapter.OSGiModuleImpl$1$1$1.loadClass(OSGiModuleImpl.java:280)
        at com.sun.hk2.component.LazyInhabitant.fetch(LazyInhabitant.java:91)
        at com.sun.hk2.component.LazyInhabitant.get(LazyInhabitant.java:106)
        at
        com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:60)
        at org.jvnet.hk2.component.Habitat$1.get(Habitat.java:252)
        at java.util.AbstractList$Itr.next(AbstractList.java:345)
        at
        com.sun.enterprise.v3.services.impl.ContainerMapper.initializeFileURLPattern(ContainerMapper.java:199)
        at
        com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:159)
        at
        com.sun.grizzly.http.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:633)
        at
        com.sun.grizzly.http.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:570)
        at
        com.sun.grizzly.http.DefaultProcessorTask.process(DefaultProcessorTask.java:827)
        at
        com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:152)
        at
        com.sun.enterprise.v3.services.impl.GlassfishProtocolChain.executeProtocolFilter(GlassfishProtocolChain.java:71)
        at
        com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:103)
        at
        com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:89)
        at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
        at
        com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:67)
        at
        com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:56)
        at
        com.sun.grizzly.util.WorkerThreadImpl.processTask(WorkerThreadImpl.java:325)
        at com.sun.grizzly.util.WorkerThreadImpl.run(WorkerThreadImpl.java:184)
        Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle
        35: package; (&(package=com.sun.enterprise.util)(version>=10.0.0.b28))
        at org.apache.felix.framework.Felix._resolveBundle(Felix.java:1725)
        at org.apache.felix.framework.Felix._startBundle(Felix.java:1588)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1541)
        at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:371)
        at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:137)
        ... 20 more

        #]
        ritzmann added a comment -

        This ought to be fixed with metro@1.4,0-5007:20081021T113248Z which we uploaded
        yesterday night.

        Bhakti Mehta added a comment -

        Fixed and verified in 28c
        http://download.java.net/glassfish/v3-prelude/promoted/glassfish-v3-prelude-b28c.zip

        Install the build
        Run UC
        Install metro
        Start server
        deploy webservice it should work now

        meenap added a comment -

        Tried B28c and this issue is fixed. Metro version is 1.4-5010, installed size is
        15.5MB. Marking issue as verified.


          People

          • Assignee:
            Bhakti Mehta
            Reporter:
            meenap
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: