glassfish
  1. glassfish
  2. GLASSFISH-6324

GF Eclipse plugin : Exception in thread "main" java.lang.RuntimeException: the domain directory is not a directory

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: other
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      6,324
    • Status Whiteboard:
      Hide

      gfv3-prelude-included

      Show
      gfv3-prelude-included

      Description

      GF eclipse plugin 1.10

      I start from a fresh installation (unzip GFv3)

      #1 - I unzip glassfish
      #2 - I start Eclipse
      #3 - I create a server : (see image) (I used the default except : I choose
      domain2 for the name)
      #4 - assign a blank dynamic project
      #5 - start the server

      PS : I don't have any domain2 in my glassfish folder.

      here the output in the Eclipse console :

      2008-09-27 14:24:45 com.sun.enterprise.glassfish.bootstrap.ASMain main
      INFO: Launching GlassFish on Apache Felix OSGi platform
      Exception in thread "main" java.lang.RuntimeException: the domain directory is
      not a directory.
      at
      com.sun.enterprise.glassfish.bootstrap.ASMainHelper.verifyDomainRoot(ASMainHelper.java:224)
      at com.sun.enterprise.glassfish.bootstrap.ASMainOSGi.<init>(ASMainOSGi.java:116)
      at
      com.sun.enterprise.glassfish.bootstrap.ASMainFelix.<init>(ASMainFelix.java:53)
      at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:65)
      Time zero is 1222539885765

        Activity

        Hide
        survivant added a comment -

        Created an attachment (id=1892)
        server settings

        Show
        survivant added a comment - Created an attachment (id=1892) server settings
        Hide
        survivant added a comment -

        it works only if I choose a domain name that already exist. I expect to receive
        a popup in Eclipse telling me to create the domain first, or create it in
        Eclipse. It will make more sens to create everything within Eclipse.

        Show
        survivant added a comment - it works only if I choose a domain name that already exist. I expect to receive a popup in Eclipse telling me to create the domain first, or create it in Eclipse. It will make more sens to create everything within Eclipse.
        Hide
        survivant added a comment -
        Show
        survivant added a comment - fill a bug in glssfish plugin https://glassfishplugins.dev.java.net/issues/show_bug.cgi?id=59
        Hide
        kumara added a comment -

        v3 defect tracking

        Show
        kumara added a comment - v3 defect tracking
        Hide
        survivant added a comment -

        from Ludovic.Champenois@sun.com

        Judy Tang wrote:

        I have not tried it. May be for now you can close it and open one under
        glassfishplugin

        No,
        See the exception: it is from the GlassFish runtime, verifying the domain content.
        So I think there is misbehaviour in the GF runtime versus the domain used by
        this runtime...

        It is not because the user uses Eclipse that the error is in the IDE...-)
        Ludo

        Show
        survivant added a comment - from Ludovic.Champenois@sun.com Judy Tang wrote: I have not tried it. May be for now you can close it and open one under glassfishplugin No, See the exception: it is from the GlassFish runtime, verifying the domain content. So I think there is misbehaviour in the GF runtime versus the domain used by this runtime... It is not because the user uses Eclipse that the error is in the IDE...-) Ludo
        Hide
        dochez added a comment -

        I changed the exception reason to : Domain directory does not exist. Yet the
        plugin should display that reason for startup failure. reassigning to ludo.

        Show
        dochez added a comment - I changed the exception reason to : Domain directory does not exist. Yet the plugin should display that reason for startup failure. reassigning to ludo.

          People

          • Assignee:
            dochez
            Reporter:
            survivant
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: