glassfish
  1. glassfish
  2. GLASSFISH-6694

cannot create cluster after adding cluster support

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 9.1.1
    • Fix Version/s: 9.1.1_dev
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Operating System: Mac OS X
      Platform: Sun

    • Issuezilla Id:
      6,694

      Description

      I am using 9.1.1 promoted build 58, and see that i cannot create cluster for the
      domain that initially has developer profile.
      Step to reproduce:

      • start a developer profile domain
      • In Admin console, click the 'Add Cluster Support' button in the Application
        Server page (i can't find the CLI command to add cluster support, is there one ?)
      • Follow instruction and press OK
      • Restart server
      • Note that this time the server log says 'Domain supports application server
        clusters and other standalone instances.', this is correct.
      • try to use CLI command to create a node-agent, works fine
      • use CLI command or GUI to create a cluster. Got the same error:

      $asadmin create-cluster X1
      Source isn't a directory
      CLI137 Command create-cluster failed.

      server log :
      [#|2008-11-02T22:01:18.662-0800|WARNING|sun-appserver9.1|javax.ee.enterprise.system.tools.admin|_ThreadID=15;_ThreadName=httpWorkerThread-4848-0;_RequestID=bdcd06a3-3508-4939-9d33-6bc07c1fcca7;|EEADM0020:
      An exception occurred copying configuration default-config to configuration
      X1-config.
      java.lang.IllegalArgumentException: Source isn't a directory
      at com.sun.enterprise.util.io.FileUtils.copyTree(FileUtils.java:994)
      at com.sun.enterprise.util.io.FileUtils.copyTree(FileUtils.java:978)
      at
      com.sun.enterprise.ee.admin.servermgmt.EEDomainsManager.copyConfigururation(EEDomainsManager.java:192)
      at
      com.sun.enterprise.ee.admin.configbeans.ConfigsConfigBean.copyConfiguration(ConfigsConfigBean.java:216)
      at
      com.sun.enterprise.ee.admin.configbeans.ConfigsConfigBean.createStandAloneConfiguration(ConfigsConfigBean.java:144)
      at
      com.sun.enterprise.ee.admin.configbeans.ClustersConfigBean.createCluster(ClustersConfigBean.java:486)
      at
      com.sun.enterprise.ee.admin.mbeans.ClustersConfigMBean.createCluster(ClustersConfigMBean.java:293)
      at
      com.sun.enterprise.ee.admin.mbeans.ClustersConfigMBean.createCluster(ClustersConfigMBean.java:364)

        Activity

        harpreet added a comment -

        Kedar - please scrub this. We will need to fix this.

        km added a comment -

        Thank you for reporting this bug. I will investigate this a little more and
        report back. I agree, this needs a fix.

        km added a comment -

        Ah, I think I know what's happening. Somehow, in GF v2.1, the folder named
        "default-config" is not getting created when "asadmin create-domain" is done
        for developer profile domain. This is definitely a change in behavior for
        v2.1. For example, if you did: asadmin create-domain --profile developer
        dev-domain on v2_02 or v2, you will see a folder created like:
        ".../domains/dev-domain/config/default-config". This folder is not created when
        the same command is executed in v2.1. I would like Yamini to comment on that.

        In the meanwhile, I will work-around this problem in DomainMBean in admin/mbeans
        such that if the folder does not exist, it will be created. This is better
        anyway. But it will be nice if we understand why the folder is not getting
        created in the first place.

        Yamini K B added a comment -

        I think this has something to do with the changes done for issue 3980 (which
        Kedar is aware of)

        km added a comment -

        Checking in mbeans/src/java/com/sun/enterprise/admin/mbeans/DomainMBean.java;
        /cvs/glassfish/admin/mbeans/src/java/com/sun/enterprise/admin/mbeans/DomainMBean.java,v
        <-- DomainMBean.java
        new revision: 1.7.6.1; previous revision: 1.7
        done

        Tested locally. Thank you for filing this issue. Regression because of fix for 3980.


          People

          • Assignee:
            km
            Reporter:
            Anissa Lam
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: