Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: OSGi-JavaEE
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      6,848

      Description

      It would be interesting if code running inside the EJB Container can performs
      calls to the OSGi framework that is already running the GF modules.
      Doing so, the benefits of OSGi (e.g. discovering services that are added during
      runtime) can be combined with the benefits you get from the EJB container.

      Another example of this is a web page that uses a Servlet to get some data. The
      code providing the data might be available as an OSGi Bundle, and should somehow
      be registered with an OSGi Framework. If the EJB Container allows direct OSGi
      calls, the Servlet can delegate the request to a Session Bean, and this one can
      query the OSGi Framework.

        Activity

        ludo added a comment -

        .

        Sanjeeb Sahoo added a comment -

        Work started. Coming soon...

        Sanjeeb Sahoo added a comment -

        closing as duplicate of 11374

            • This issue has been marked as a duplicate of 11374 ***

          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            johanvos
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: