Issue Details (XML | Word | Printable)

Key: GLASSFISH-7019
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Critical Critical
Assignee: Martin Grebac
Reporter: survivant
Votes: 0
Watchers: 3
Operations

If you were logged in you would be able to see more operations.
glassfish

GFv3 build31 doesn't start after installation

Created: 09/Jan/09 03:25 PM   Updated: 27/Nov/10 01:26 PM   Resolved: 28/Aug/09 02:24 PM
Component/s: packaging
Affects Version/s: V3
Fix Version/s: V3

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: All


Issuezilla Id: 7,019
Tags:
Participants: Martin Grebac, nluu, ritzmann, Snjezana Sevo-Zenzerovic, survivant and vince kraemer


 Description  « Hide

I juts try to install it.. at the end I got theses messages

Update tools and Glassfish : NOT CONFIGURED in red.. is it normal ?

here the logs

Configuration Report
Component Status Log File System Error Product Error Next Steps
Documentation and other References
updatetool 0.5 Not Configured Log File
None http://docs.sun.com/doc/820-5968 http://docs.sun.com/doc/820-5968
glassfish 0.5 Not Configured Log File
None http://docs.sun.com/doc/820-5968 http://docs.sun.com/doc/820-5968

file:///C:/Documents%20and%20Settings/Administrator/Local%20Settings/Temp/2009-01-08-19-05-install.log

[#|2009-01-08T19:04:58.770-05:00|INFO|Install
Engine|org.openinstaller.provider.task.TaskDriver|arg0=prod\=updatetool|OP_REGISTER:Registering|#]
[#|2009-01-08T19:04:58.801-05:00|INFO|Install
Engine|org.openinstaller.provider.task.TaskDriver|arg0=pkg\=glassfish.zip;arg1=prod\=glassfish|OP_INSTALL:Installing
package|#]

[#|2009-01-08T19:04:58.816-05:00|INFO|Install
Engine|org.openinstaller.pkg.ZIPPackageUtils|arg0=file\=C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\glassfish-v3-ea-b31-windows.exe2\Product\Packages\



Snjezana Sevo-Zenzerovic added a comment - 09/Jan/09 03:39 PM

Well, needless to say, it is not normal

Real culprit is this line from installation log:

[#|2009-01-08T19:05:20.582-05:00|INFO|Install
Engine|org.openinstaller.provider.conf.InstallationConfigurator||Uncompressing
C:\glassfishv3\glassfish\modules\jaxb.pack.gz:[Uncompressing
C:\glassfishv3\glassfish\modules\jaxb.pack.gz]*[{0} {1}]|#]

[#|2009-01-08T19:05:21.285-05:00|INFO|Install
Engine|org.openinstaller.provider.conf.InstallationConfigurator||Error
uncompressing file:duplicate entry:
com/sun/xml/bind/unmarshaller/Patcher.class:[Error uncompressing file:duplicate
entry: com/sun/xml/bind/unmarshaller/Patcher.class]*[{0} {1}]|#]

It seems that compressed jaxb.jar file contains duplicate entries which cannot
be properly unpacked by MacOS and Windows JDK installations. For some reason,
this works on Solaris... Given that this is fatal error (and should have been
logged as error instead of info message), configurator will not bother to
proceed and create the domain.

I am moving this to packaging as more appropriate subcategory. Jar normalization
process performed in packager should have taken care of this, so need to
investigate if this is happening as expected for this jar. Of course, it would
be nice if jaxb.jar did not have duplicate content in the first place, too.

Note that this affects only installer based full glassfish distributions. web
distributions and zip based full glassfish distribution do not contain
compressed jaxb.jar so you can fall back on those until this issue is resolved.


nluu added a comment - 23/Jan/09 03:53 PM

Please resolve this issue asap. Thanks!


ritzmann added a comment - 26/Jan/09 12:54 AM

Looks indeed like at least some classes under com/sun/xml/bind are present
twice in the OSGi jar. The normal JAXB jars that go into the OSGi bundle don't
seem to have these duplicates. I am investigating the OSGi build.


ritzmann added a comment - 26/Jan/09 04:47 AM

The problem is caused by merging jaxb1-impl.jar back into the OSGi bundle.
jaxb1-impl.jar contains a second copy of com/sun/xml/bind/unmarshaller/
Patcher.class. Martin, could you please advise? It hardly seems intentional
because on the classpath one of the two classes would be hidden by the other.


ritzmann added a comment - 26/Jan/09 04:52 AM

In case I didn't express myself clearly - both jaxb-impl.jar and jaxb1-impl.jar
contain a file com/sun/xml/bind/unmarshaller/Patcher.class. We process jaxb-
impl.jar with the OSGi bnd tool and then add the contents of jaxb1-impl.jar to
the bundle.


ritzmann added a comment - 26/Jan/09 05:52 AM

The class Patcher seems to be virtually identical in JAXB 1 and 2. I modified
the JAXB OSGi build script to include only the one from JAXB 2. The change will
become available with tonight's build.

Martin, I am not sure this is really the right long-term fix. Should we open a
JAXB issue?


Martin Grebac added a comment - 26/Jan/09 07:14 AM

I removed the class from trunk, if everything passes fine I'll remove it from 21
branch as well.


ritzmann added a comment - 27/Jan/09 01:44 AM

I removed the exclude statement from the osgi/build.xml on the trunk. Martin,
when you remove the Patcher class from the branch, please update the build
script as well.


Snjezana Sevo-Zenzerovic added a comment - 27/Jan/09 05:25 PM

I checked in temporary workaround in GF distributions-ips module - jaxb-osgi.jar
is temporarily excluded from jar compression during the assembly of installer
distribution.

Martin, once you resolve this issue in jaxb build and you integrate new jaxb
version into GlassFish top level pom.xml please let me know and I will revert
the workaround.


vince kraemer added a comment - 19/Mar/09 04:53 PM

there is other bits of fallout from this, as users start to work with v3 inside
NetBeans. NetBeans doesn't like the duplicate entries either.


Snjezana Sevo-Zenzerovic added a comment - 28/Aug/09 02:24 PM

FWIW, this issue has been fixed and jaxb-osgi.jar does not contain duplicate
entries anymore. Only remaining task was to enable jar packing of this jar for
GF installer distribution and that is now in place. Marking as fixed.