glassfish
  1. glassfish
  2. GLASSFISH-7038

jdk check not integrated into start-up processing

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: 3.1
    • Component/s: build_system
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: Sun

    • Issuezilla Id:
      7,038
    • Status Whiteboard:

      v3_exclude

      Show
      v3_exclude

      Description

      If I attempt to start v3 build 31 with jdk 5, the error message is not helpful.

      > java -version
      java version "1.5.0_16"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b02)
      Java HotSpot(TM) Server VM (build 1.5.0_16-b02, mixed mode)
      > glassfishv3/glassfish/bin/asadmin start-domain
      java.lang.NoClassDefFoundError: javax/xml/stream/XMLStreamException
      Command start-domain failed.

        Activity

        janey added a comment -

        after fixing this in the build, I'll change the subcategory back to CLI.

        Thanks,
        Jane

        vince kraemer added a comment -
            • Issue 8627 has been marked as a duplicate of this issue. ***
        janey added a comment -

        I have changed the javac option in master-pom/pom.xml to 1.6. However, majority of the v3
        modules are compiled with "hk2-maven-plugin" and the goal, "hk2-compile" invokes APT and it's
        explicitly sets the -source option to 1.5. See: https://hk2.dev.java.net/hk2-maven-plugin/hk2-
        compile-mojo.html.

        Since JDK 1.6 provides direct support for annotation processing (which btw wasn't supported in JDK
        1.5), there is no need to invoke APT. The "hk2-maven-plugin" should directly invoke javac if using JDK
        1.6.

        However, at this point since we're so close to HCF and considering that this change is fairly risky plus
        the current build system is not causing any issue with ADT, I propose that we lower this bug to P3 and
        revisit after HCF.

        kumara added a comment -

        Setting target release for unresolved issues submitted on v3 release to the next release. Not changing
        issues submitted on v2.x release because they might not apply to v3.next release.

        janey added a comment -

        The original bug is about asadmin's error message is not helpful if jdk 5 is used to start domain. The
        end users of GlassFish will not really care if the classes are compiled with "49" as the major version.

        "asadmin" error messages have improved since this bug was opened.
        executing "aadmin start-domain" with jdk5 now returns the following message:

        ./asadmin start-domain
        GlassFish requires Java SE version 6. Your JDK is version 5

        Modifying hk2-maven-plugin will require some work. I'm closing this bug as fixed since the output of
        asadmin is reporting the correct message.


          People

          • Assignee:
            janey
            Reporter:
            vince kraemer
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: