Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: cmp
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: Sun

    • Issuezilla Id:
      7,243

      Description

      V3 b37. I've tried to deploy cmp sample from AS 9.1 samples: cmpcustomer.

      But the deployment failed with such message:
      =============================================================

      [#|2009-02-27T16:40:57.574-0800|INFO|glassfish|null|_ThreadID=15;_ThreadName=Thread-3;|time
      to read application.xml 42|#]

      [#|2009-02-27T16:40:59.132-0800|SEVERE|glassfish|javax.enterprise.system.core|_ThreadID=15;_ThreadName=Thread-3;|Exception
      while deploying the app
      java.lang.RuntimeException: null uri does not point to a web bundle

      =========================================================================

      I've attached the archive, and a small script that creates jdbc resources. See
      the full error message at the bottom:

      ==============================================

      [#|2009-02-27T16:40:57.500-0800|FINE|glassfish|javax.enterprise.system.util|_ThreadID=15;_ThreadName=Thread-3;ClassName=null;MethodName=null;/opt/glassfishv3/glassfish/domains/domain1/applications/cmpcustomer;|UTIL6049:
      Attempt to delete
      /opt/glassfishv3/glassfish/domains/domain1/applications/cmpcustomer failed; the
      file is reported as non-existent|#]

      [#|2009-02-27T16:40:57.528-0800|INFO|glassfish|null|_ThreadID=15;_ThreadName=Thread-3;|Deployment
      expansion took 26|#]

      [#|2009-02-27T16:40:57.530-0800|FINE|glassfish|javax.enterprise.system.util|_ThreadID=15;_ThreadName=Thread-3;ClassName=null;MethodName=null;/opt/glassfishv3/glassfish/domains/domain1/generated/xml/cmpcustomer;|UTIL6049:
      Attempt to delete
      /opt/glassfishv3/glassfish/domains/domain1/generated/xml/cmpcustomer failed; the
      file is reported as non-existent|#]

      [#|2009-02-27T16:40:57.530-0800|FINE|glassfish|javax.enterprise.system.util|_ThreadID=15;_ThreadName=Thread-3;ClassName=null;MethodName=null;/opt/glassfishv3/glassfish/domains/domain1/generated/ejb/cmpcustomer;|UTIL6049:
      Attempt to delete
      /opt/glassfishv3/glassfish/domains/domain1/generated/ejb/cmpcustomer failed; the
      file is reported as non-existent|#]

      [#|2009-02-27T16:40:57.530-0800|FINE|glassfish|javax.enterprise.system.util|_ThreadID=15;_ThreadName=Thread-3;ClassName=null;MethodName=null;/opt/glassfishv3/glassfish/domains/domain1/generated/jsp/cmpcustomer;|UTIL6049:
      Attempt to delete
      /opt/glassfishv3/glassfish/domains/domain1/generated/jsp/cmpcustomer failed; the
      file is reported as non-existent|#]

      [#|2009-02-27T16:40:57.574-0800|INFO|glassfish|null|_ThreadID=15;_ThreadName=Thread-3;|time
      to read application.xml 42|#]

      [#|2009-02-27T16:40:59.132-0800|SEVERE|glassfish|javax.enterprise.system.core|_ThreadID=15;_ThreadName=Thread-3;|Exception
      while deploying the app
      java.lang.RuntimeException: null uri does not point to a web bundle
      at
      com.sun.enterprise.deployment.node.runtime.application.ApplicationRuntimeNode.setElementValue(ApplicationRuntimeNode.java:170)
      at
      com.sun.enterprise.deployment.node.SaxParserHandler.endElement(SaxParserHandler.java:441)
      at
      com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(AbstractSAXParser.java:601)
      at
      com.sun.org.apache.xerces.internal.impl.dtd.XMLNSDTDValidator.endNamespaceScope(XMLNSDTDValidator.java:263)
      at
      com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.handleEndElement(XMLDTDValidator.java:2028)
      at
      com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.endElement(XMLDTDValidator.java:901)
      at
      com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(XMLDocumentFragmentScannerImpl.java:1774)
      at
      com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2930)
      at
      com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
      at
      com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:140)
      at
      com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
      at
      com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
      at
      com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
      at
      com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
      at
      com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
      at
      com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
      at javax.xml.parsers.SAXParser.parse(SAXParser.java:395)
      at
      com.sun.enterprise.deployment.io.DeploymentDescriptorFile.read(DeploymentDescriptorFile.java:289)
      at
      com.sun.enterprise.deployment.archivist.Archivist.readRuntimeDeploymentDescriptor(Archivist.java:581)
      at
      com.sun.enterprise.deployment.archivist.ApplicationArchivist.openWith(ApplicationArchivist.java:235)
      at
      org.glassfish.javaee.core.deployment.DolProvider.load(DolProvider.java:97)
      at
      org.glassfish.javaee.core.deployment.DolProvider.load(DolProvider.java:34)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.loadDeployer(ApplicationLifecycle.java:512)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.setupContainerInfos(ApplicationLifecycle.java:457)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:212)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:172)
      at
      org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:257)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$2.execute(CommandRunnerImpl.java:292)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:307)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:438)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:128)
      at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:289)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:179)
      at
      com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:147)
      at
      com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:181)
      at
      com.sun.grizzly.http.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:646)
      at
      com.sun.grizzly.http.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
      at
      com.sun.grizzly.http.DefaultProcessorTask.process(DefaultProcessorTask.java:821)
      at
      com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:153)
      at
      com.sun.enterprise.v3.services.impl.GlassfishProtocolChain.executeProtocolFilter(GlassfishProtocolChain.java:71)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:103)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:89)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at
      com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:67)
      at
      com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:56)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)

      #]

        Activity

        easarina added a comment -

        Created an attachment (id=2302)
        archive

        easarina added a comment -

        Created an attachment (id=2303)
        script

        Hong Zhang added a comment -

        Yeah, I noticed the null uri exception when I was working on something else. The
        fix for this has already been checked in yesterday.

        When I tried to deploy the war with latest build just now, I got this:

        hzhang@nmr:~/files/sun/glassfish/bin$ ./asadmin deploy
        ~/downloads/7243/cmpcustomer.ear
        remote failure: Exception while loading the app : java.lang.RuntimeException:
        Error during EjbApplication.start()

        Command deploy failed.

        I am not sure about the current status of cmp support. I know Marina has been
        working on it. Assign to her for further follow up.

        marina vatkina added a comment -

        CMP is there. The NPE comes from not processed correctly DDs:

        Caused by: java.lang.NullPointerException
        at
        com.sun.enterprise.deployment.MethodDescriptor.getMethodDescriptorsOfName(MethodDescriptor.java:430)
        at
        com.sun.enterprise.deployment.MethodDescriptor.doStyleConversion(MethodDescriptor.java:405)
        at
        com.sun.enterprise.deployment.EjbDescriptor.convertMethodContainerTransactionsOfStyle(EjbDescriptor.java:928)
        at
        com.sun.enterprise.deployment.EjbDescriptor.convertMethodContainerTransactions(EjbDescriptor.java:914)
        at
        com.sun.enterprise.deployment.EjbDescriptor.getContainerTransactionFor(EjbDescriptor.java:881)

        Hong Zhang added a comment -

        Marina: I have fixed the NPE in DOL and just checked in the changes. Right now
        I am seeing this ResolveError. Can you take a look? Thanks.

        [#|2009-03-02T13:25:06.886-0500|SEVERE|glassfish|javax.enterprise.system.tools.admin|_ThreadID=15;_ThreadName=Thread-1;|Exception
        in command execution : com.sun.enterprise.module.ResolveError: Failed to start
        org.glassfish.persistence.cmp.cmp-support-ejb(support ejb module for
        cmp):3.0.0.SNAPSHOT
        com.sun.enterprise.module.ResolveError: Failed to start
        org.glassfish.persistence.cmp.cmp-support-ejb(support ejb module for
        cmp):3.0.0.SNAPSHOT
        at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:143)
        at
        org.jvnet.hk2.osgiadapter.OSGiModuleImpl$1$1$1.loadClass(OSGiModuleImpl.java:280)
        at com.sun.hk2.component.LazyInhabitant.fetch(LazyInhabitant.java:91)
        at com.sun.hk2.component.LazyInhabitant.get(LazyInhabitant.java:106)
        at
        com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:60)
        at org.jvnet.hk2.component.Habitat.getByContract(Habitat.java:561)
        at
        org.glassfish.ejb.startup.EjbDeployer.generateArtifacts(EjbDeployer.java:144)
        at
        org.glassfish.javaee.core.deployment.JavaEEDeployer.prepare(JavaEEDeployer.java:139)
        at
        com.sun.enterprise.v3.server.ApplicationLifecycle.prepareModule(ApplicationLifecycle.java:553)
        at
        org.glassfish.javaee.core.deployment.EarDeployer.prepareBundle(EarDeployer.java:261)
        at
        org.glassfish.javaee.core.deployment.EarDeployer.access$100(EarDeployer.java:73)

        marina vatkina added a comment -

        After Hong's fix to the NPE I can now deploy the attached ear file (and do not
        see the ResolveError). So marking this issue as fixed.


          People

          • Assignee:
            Mitesh Meswani
            Reporter:
            easarina
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: