glassfish
  1. glassfish
  2. GLASSFISH-7362

JPA cache is not valid after a series of EntityManager operations

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: v2.1
    • Fix Version/s: 3.1_dev
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: PC

    • Issuezilla Id:
      7,362
    • Status Whiteboard:

      v3_exclude

      Show
      v3_exclude

      Description

      I encountered OptimisticLockException when running JPA app wich
      enables session cache. I looked into the runtime and found that
      the cause of OptimisticLockException seems to be related to the
      session cache. and when I disabled session cache the app ran
      successfully.

      I think this issue is related to the following.
      https://bugs.eclipse.org/bugs/show_bug.cgi?id=241388
      and this problem is resolved by EclipseLink1.0.1

      and the attached file is a simple sample(a SE app) for reproducing
      the phenomenon.

        Activity

        Wu Jie added a comment -

        Created an attachment (id=2400)
        the result of excuting the simlified app

        Wu Jie added a comment -

        Created an attachment (id=2401)
        the preliminary analysis of the problem

        Mitesh Meswani added a comment -

        v3_exclude as it is confirmed to be fixed in EclipseLink

        hegalor added a comment -

        I got the "phantom" OptimistcLockException, too. (GF 2.1.1)

        Perhaps this issue has same cause:
        https://glassfish.dev.java.net/issues/show_bug.cgi?id=6936

        Und perhaps both are caused by this TPE problem:
        http://forums.oracle.com/forums/thread.jspa?threadID=453117

        Mitesh Meswani added a comment -

        The issue is fixed in EclipseLink, the default provider for GlassFish 3.1. Marking
        as fixed


          People

          • Assignee:
            tware
            Reporter:
            Wu Jie
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: