glassfish
  1. glassfish
  2. GLASSFISH-752

Cannot deploy WS created from WSDL that imports another WSDL

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.0peur1_dev
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      752
    • Status Whiteboard:

      needfix-9.0peur1

      Show
      needfix-9.0peur1

      Description

      This is possible when WS is generated before deployment (using wsgen).

      Seems that GlassFish container is not able to retrieve imported wsdl file.

      1. EJBModule1.tar
        140 kB
        mkuchtiak
      2. Foo.wsdl
        2 kB
        mkuchtiak
      3. FooImpl.java
        0.8 kB
        mkuchtiak
      4. FooWrapper.wsdl
        0.7 kB
        mkuchtiak
      5. schema2.xsd
        1.0 kB
        mkuchtiak

        Activity

        mkuchtiak added a comment -

        Created an attachment (id=295)
        Wrapper WSDL file

        mkuchtiak added a comment -

        Created an attachment (id=296)
        imported wsdl file

        mkuchtiak added a comment -

        Created an attachment (id=297)
        imported schema file

        mkuchtiak added a comment -

        Created an attachment (id=298)
        WS Implementation class

        mkuchtiak added a comment -

        Server log message :
        error: failed to parse document at "http://localhost:8080/FooService/Foo.wsdl":
        java.io.FileNotFoundException: http://localhost:8080/FooService/Foo.wsdl|#]
        Invoking wsimport with http://localhost:8080/FooService/FooImpl?WSDL
        wsimport successful

        Tester Page (http://localhost:8080/FooService/FooImpl?Tester) output :

        Exceptions details : java.lang.RuntimeException: Service Class not generated as
        expected
        javax.servlet.ServletException: java.lang.RuntimeException: Service Class not
        generated as expected at
        com.sun.enterprise.webservice.monitoring.WebServiceTesterServlet.initializePort(WebServiceTesterServlet.java:545)
        at
        com.sun.enterprise.webservice.monitoring.WebServiceTesterServlet.doGet(WebServiceTesterServlet.java:157)
        at
        com.sun.enterprise.webservice.monitoring.WebServiceTesterServlet.invoke(WebServiceTesterServlet.java:103)
        at
        com.sun.enterprise.webservice.EjbWebServiceServlet.service(EjbWebServiceServlet.java:94)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820) at
        com.sun.enterprise.web.AdHocContextValve.invoke(AdHocContextValve.java:100) at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:566) at
        org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:536) at
        com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:71) at
        org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:182) at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:566) at
        com.sun.enterprise.web.VirtualServerPipeline.invoke(VirtualServerPipeline.java:120)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:939) at
        org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:137)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:566)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:536)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:939) at
        org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:231) at
        com.sun.enterprise.web.connector.grizzly.ProcessorTask.invokeAdapter(ProcessorTask.java:667)
        at
        com.sun.enterprise.web.connector.grizzly.ProcessorTask.processNonBlocked(ProcessorTask.java:574)
        at
        com.sun.enterprise.web.connector.grizzly.ProcessorTask.process(ProcessorTask.java:844)
        at
        com.sun.enterprise.web.connector.grizzly.ReadTask.executeProcessorTask(ReadTask.java:287)
        at com.sun.enterprise.web.connector.grizzly.ReadTask.doTask(ReadTask.java:212)
        at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:252) at
        com.sun.enterprise.web.connector.grizzly.WorkerThread.run(WorkerThread.java:75)
        Caused by: java.lang.RuntimeException: Service Class not generated as expected
        at
        com.sun.enterprise.webservice.monitoring.WebServiceTesterServlet.initializePort(WebServiceTesterServlet.java:520)
        ... 24 more

        mkuchtiak added a comment -

        Created an attachment (id=299)
        Entire Netbeans project

        mkuchtiak added a comment -

        Created an attachment (id=300)
        Netbeans project as zip file

        mkuchtiak added a comment -

        This is an important feature.
        In WS books, there is a recommedation to use wsdl:import and to keep wsdl
        elements in different files to obtain more flexibility.

        This is also a blocker for Netbeans WS Support.

        gfbugbridge added a comment -

        <BT6443445>

        vijaysr added a comment -

        reassigned owner

        vijaysr added a comment -

        Fix checked in GFv2 and UR1b04


          People

          • Assignee:
            vijaysr
            Reporter:
            mkuchtiak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: