glassfish
  1. glassfish
  2. GLASSFISH-819

poor message when J2EE 1.4 ejb jar doesn't contain a bean

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 9.0peur1
    • Fix Version/s: 9.0pe
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: PC

    • Issuezilla Id:
      819

      Description

      bin/asadmin deploy ~/EnterpriseApplication2/dist/EnterpriseApplication2.ear
      CLI171 Command deploy failed : Deploying application in domain failed; Error
      loading deployment descriptors for module [EnterpriseApplication2] Line 5 Column
      22 – Deployment descriptor file META-INF/ejb-jar.xml in archive
      [EnterpriseApplication2-ejb.jar]. cvc-complex-type.2.4.b: The content of
      element 'enterprise-beans' is not complete. One of
      '

      {"http://java.sun.com/xml/ns/j2ee":session, "http://java.sun.com/xml/ns/j2ee":entity, "http://java.sun.com/xml/ns/j2ee":message-driven}

      ' is expected.

      The message for a Java EE 5 ejb jar is better...

      vbk@ubuntuabihsot:~/Desktop/glassfishV1U1B3$ bin/asadmin deploy
      ~/EnterpriseApplication1/dist/EnterpriseApplication1.ear
      CLI171 Command deploy failed : Deploying application in domain failed; Error
      loading deployment descriptors for module [EnterpriseApplication1] – Invalid
      ejb jar EnterpriseApplication1-ejb.jar: it contains zero ejb. A valid ejb jar
      requires at least one session/entity/message driven bean.

      You would think that they would be the same.....

        Issue Links

          Activity

          Hong Zhang added a comment -

          I agree the second message is more meaningful than the first one.
          However, the first error message came out from the schema validation code (due
          to the ejb-jar.xml doesn't conform to ejb schema). This part of validation code
          gets executed first.
          It is almost impossible for us to parse all the schema validation error messages
          and translate them to more meaningful messages.
          The schema error message, though not pretty, should be sufficient to point to
          the user where the problem is and which element of the xml file they need to fix.

          vince kraemer added a comment -

          I don't think we need to "parse all the schema validation error messages
          and translate them to more meaningful messages" to resolve this particular issue.

          pjiricka added a comment -

          I must say I am not a fan of the "don't know how to fix -> RESOLVED/WONTFIX"
          mentality. A better attitude would be "we'll think about how this could be
          improved".

          > The schema error message, though not pretty, should be sufficient to point to
          > the user where the problem is and which element of the xml file they need to
          > fix.

          I disagree. We saw many users that were confused by this message and did not
          know where to go from there.

          Hong Zhang added a comment -

          I will think more about this one.

          In the meantime, I think the bug from netbeans really should be fixed whether
          the priority is P2 or P3.
          http://www.netbeans.org/issues/show_bug.cgi?id=50323

          That is the root cause of the problem.

          vince kraemer added a comment -

          error message improvement initiative


            People

            • Assignee:
              Hong Zhang
              Reporter:
              vince kraemer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: